-
-
Notifications
You must be signed in to change notification settings - Fork 3.2k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
libllvm: add libcompiler-rt subpackage
Fixes #2403.
- Loading branch information
Showing
3 changed files
with
58 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
TERMUX_SUBPKG_DESCRIPTION="Compiler runtime libraries for clang" | ||
TERMUX_SUBPKG_INCLUDE=" | ||
lib/clang/*/bin/asan_device_setup | ||
lib/clang/*/bin/hwasan_symbolize | ||
lib/clang/*/include/fuzzer/FuzzedDataProvider.h | ||
lib/clang/*/include/profile/InstrProfData.inc | ||
lib/clang/*/include/sanitizer/ | ||
lib/clang/*/include/xray/ | ||
lib/clang/*/lib/android/ | ||
lib/clang/*/share/asan_blacklist.txt | ||
lib/clang/*/share/cfi_blacklist.txt | ||
lib/clang/*/share/hwasan_blacklist.txt | ||
" |
39 changes: 39 additions & 0 deletions
39
packages/libllvm/projects-compiler-rt-CMakeLists.txt.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
--- ../projects-compiler-rt-CMakeLists.txt.orig 2020-09-22 14:12:54.771097201 +0000 | ||
+++ ./projects/compiler-rt/CMakeLists.txt 2020-09-22 16:11:07.568559345 +0000 | ||
@@ -114,7 +114,7 @@ | ||
endif() | ||
pythonize_bool(ANDROID) | ||
|
||
-set(ANDROID_NDK_VERSION 18 | ||
+set(ANDROID_NDK_VERSION 24 | ||
CACHE STRING "Set this to the Android NDK version that you are using") | ||
|
||
set(COMPILER_RT_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}) | ||
@@ -182,6 +182,9 @@ | ||
elseif (FUCHSIA) | ||
set(${var}_LIBNAME "libc++") | ||
set(${var}_INTREE 1) | ||
+ elseif (ANDROID) | ||
+ set(${var}_LIBNAME "libc++_shared") | ||
+ set(${var}_SYSTEM 1) | ||
else() | ||
set(${var}_LIBNAME "libstdc++") | ||
set(${var}_SYSTEM 1) | ||
@@ -196,7 +199,7 @@ | ||
# which pulls in the ABI transitively. | ||
set(SANITIZER_CXX_ABI "default" CACHE STRING | ||
"Specify C++ ABI library to use.") | ||
-set(CXXABIS none default libstdc++ libc++ libcxxabi) | ||
+set(CXXABIS none default libc++_shared libstdc++ libc++ libcxxabi) | ||
set_property(CACHE SANITIZER_CXX_ABI PROPERTY STRINGS ;${CXXABIS}) | ||
handle_default_cxx_lib(SANITIZER_CXX_ABI) | ||
|
||
@@ -438,6 +441,8 @@ | ||
list(APPEND SANITIZER_CXX_ABI_LIBRARIES "c++abi") | ||
elseif (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libstdc++") | ||
append_list_if(COMPILER_RT_HAS_LIBSTDCXX stdc++ SANITIZER_CXX_ABI_LIBRARIES) | ||
+elseif (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libc++_shared") | ||
+ list(APPEND SANITIZER_CXX_ABI_LIBRARIES "c++_shared") | ||
endif() | ||
|
||
if (SANITIZER_TEST_CXX_LIBNAME STREQUAL "libc++") |