Skip to content

Commit

Permalink
devel/gearmand: Update to 1.1.18.
Browse files Browse the repository at this point in the history
Based on a PR by @mmoll, see #31

Upstream changelog
==================

1.1.18
- HTTP protocol bug fix
- configure.sh accepts -o flag
- Build and test cleanly on OS X with latest xcode

1.1.17
- Redis fixed for items larger than 64 bytes
- Various memcached plugin bugfixes
- Shellcheck passes for bootstrap.sh

1.1.16
- Fixes to HTTP protocol plugin and background jobs
- Redis queue plugin refactored
- TCP Keepalive settings are properly respected
- Various fixes for stricter C++11 compilation
- Changed from CYaSSL to WolfSSL
- Various fixes to memcached queue plugin

1.1.15
- Added "prioritystatus" command to display queued jobs broken down by
  priority.
- Turn on artifact storage
- Use _exit() in fork test to fix race
- add "redis-password" option to redis

1.1.14
- This includes significant fixes for the redis queue backend, and
  various minor bug fixes.


1.1.12 Sun Feb  9 04:27:38 PST 2014
- GEARMAN_SERVERS environmental variable for libgearman to pick up
  servers to communicate with. This means that any driver now linked
with libgearman will be able to handle multiple servers.
- Add INFO level messages for queue creation.

1.1.11 Thu Oct  3 04:38:47 EDT 2013
- Workers which return a bad gearman_return_t will be counted as an
  error by the server and not a final (i.e. they will be retried).
- Fixed possible bug where the server would over count the number of
  NOOP sent if NOOP messages did not get sent.

1.1.10 Mon Sep 16 04:20:13 CDT 2013
- Added gearman_job_use_client()
- Improve compile time.
- Fix for NOOP failure (bad worker causes early exit of loop).
- Fix for postgres (use INFORMATION_SCHEMA).
- Added gearman_client_has_active_tasks() so that you can see if a
  client has active tasks that it is working on.

1.1.9 Fri Aug  2 02:39:25 EDT 2013
- Added gearman_task_is_finished()
- Improved SSL support.
- Exceptions are now supported.
- gearmand excepts its root CA via the environmental variable
  GEARMAND_PORT.
- libgearman will now except GEARMAND_CA_CERTIFICATE,
  GEARMAN_CLIENT_PEM, and GEARMAN_CLIENT_KEY

1.1.8 Thu Jun  6 18:47:01 EDT 2013
- Postgres test case now passes.
- SSL support added.
- OSX fixes.

1.1.7 Mon May  6 06:46:20 EDT 2013
- Cleanup of error codes returned by gearmand.
- gearmand will now set its port from the env variable GEARMAND_PORT.
- Fix issue where identifier might not be set correctly on reconnect.

1.1.6 Tue Apr 16 03:29:57 EDT 2013
- Merge of 1.0.4 tree
- Added support for gearadmin to "cancel" a job.
- Keep-alive support for gearmand has been extended (more options to
  control behavior).
- Fixed issues related to clients who didn't really support exceptions
  being passed exceptions.

1.1.5 Mon Feb  4 00:59:19 EST 2013
- Rollup of bug fixes for 1.0.3
- --threads=0 for gearmand will now result in gearmand using all
  available cores.

1.1.4 Mon Dec 17 21:24:16 EST 2012
- Add GEARMAN_CLIENT_GENERATE_UNIQUE, with default set to not
  generate.
- Experimental addition to queue service which will allow a queue to
  be stored on shutdown (--libsqlite3-store-on-shutdown).
- Rollup of all changes in 1.0.2

1.1.3 Wed Nov  7 22:48:21 EST 2012
- Merge with 1.0.1

1.1.2 Fri Oct 12 05:34:29 EDT 2012
- Merge with 0.41

1.1.1 Wed Sep 19 22:04:56 EDT 2012
- Merge with 0.39

1.1.0 Wed Sep  5 08:33:37 PDT 2012
- Fix for ABI compatibility issues.
  • Loading branch information
mamash committed Aug 23, 2018
1 parent bd88eea commit b6702b8
Show file tree
Hide file tree
Showing 6 changed files with 21 additions and 137 deletions.
12 changes: 8 additions & 4 deletions devel/gearmand/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,10 @@
# $NetBSD: Makefile,v 1.32 2018/08/16 18:54:28 adam Exp $
# $NetBSD: Makefile,v 1.33 2018/08/23 08:21:02 fhajny Exp $

DISTNAME= gearmand-1.0.6
PKGREVISION= 29
DISTNAME= gearmand-1.1.18
CATEGORIES= devel
MASTER_SITES= https://launchpad.net/gearmand/1.0/1.0.6/+download/
MASTER_SITES= ${MASTER_SITE_GITHUB:=gearman/}
GITHUB_PROJECT= gearmand
GITHUB_RELEASE= ${PKGVERSION_NOREV}

MAINTAINER= filip@joyent.com
HOMEPAGE= http://gearman.org/
Expand All @@ -17,15 +18,18 @@ USE_LANGUAGES= c gnu++03

CONFIGURE_ARGS+= --enable-jobserver=no
CONFIGURE_ARGS+= --disable-libdrizzle
CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-libs}

.include "options.mk"

PKGCONFIG_OVERRIDE+= support/gearmand.pc.in

.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/gperf/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../devel/libexecinfo/buildlink3.mk"
.include "../../devel/libuuid/buildlink3.mk"
.include "../../security/libssh2/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
9 changes: 6 additions & 3 deletions devel/gearmand/PLIST
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
@comment $NetBSD: PLIST,v 1.1 2013/10/04 07:03:37 fhajny Exp $
@comment $NetBSD: PLIST,v 1.2 2018/08/23 08:21:02 fhajny Exp $
bin/gearadmin
bin/gearman
include/libgearman-1.0/actions.h
include/libgearman-1.0/aggregator.h
include/libgearman-1.0/allocator.h
include/libgearman-1.0/argument.h
include/libgearman-1.0/cancel.h
include/libgearman-1.0/client.h
include/libgearman-1.0/client_callbacks.h
include/libgearman-1.0/configure.h
Expand All @@ -14,14 +15,16 @@ include/libgearman-1.0/core.h
include/libgearman-1.0/execute.h
include/libgearman-1.0/function.h
include/libgearman-1.0/gearman.h
include/libgearman-1.0/interface/client.h
include/libgearman-1.0/interface/job.h
include/libgearman-1.0/interface/status.h
include/libgearman-1.0/interface/task.h
include/libgearman-1.0/interface/worker.h
include/libgearman-1.0/job.h
include/libgearman-1.0/job_handle.h
include/libgearman-1.0/kill.h
include/libgearman-1.0/limits.h
include/libgearman-1.0/ostream.hpp
include/libgearman-1.0/packet.h
include/libgearman-1.0/parse.h
include/libgearman-1.0/priority.h
include/libgearman-1.0/protocol.h
Expand All @@ -33,7 +36,6 @@ include/libgearman-1.0/strerror.h
include/libgearman-1.0/string.h
include/libgearman-1.0/task.h
include/libgearman-1.0/task_attr.h
include/libgearman-1.0/universal.h
include/libgearman-1.0/util.h
include/libgearman-1.0/version.h
include/libgearman-1.0/visibility.h
Expand Down Expand Up @@ -119,6 +121,7 @@ man/man3/gearman_job_send_warning.3
man/man3/gearman_job_st.3
man/man3/gearman_job_take_workload.3
man/man3/gearman_job_unique.3
man/man3/gearman_job_use_client.3
man/man3/gearman_job_workload.3
man/man3/gearman_job_workload_size.3
man/man3/gearman_log_fn.3
Expand Down
3 changes: 2 additions & 1 deletion devel/gearmand/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.5 2018/08/16 18:54:28 adam Exp $
# $NetBSD: buildlink3.mk,v 1.6 2018/08/23 08:21:02 fhajny Exp $

BUILDLINK_TREE+= gearmand

Expand All @@ -13,6 +13,7 @@ BUILDLINK_PKGSRCDIR.gearmand?= ../../devel/gearmand
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../devel/libexecinfo/buildlink3.mk"
.include "../../devel/libuuid/buildlink3.mk"
.include "../../security/libssh2/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.endif # GEARMAND_BUILDLINK3_MK
Expand Down
12 changes: 5 additions & 7 deletions devel/gearmand/distinfo
Original file line number Diff line number Diff line change
@@ -1,17 +1,15 @@
$NetBSD: distinfo,v 1.3 2015/11/03 03:27:27 agc Exp $
$NetBSD: distinfo,v 1.4 2018/08/23 08:21:02 fhajny Exp $

SHA1 (gearmand-1.0.6.tar.gz) = 872d5e13c20a29a20e45df3afa8f3981dc52d363
RMD160 (gearmand-1.0.6.tar.gz) = 44f1caead6fbd7e6a440be3275098bd798a807d0
SHA512 (gearmand-1.0.6.tar.gz) = 90e79935760ac1279b8fc82dff619e9c54b0f2d30e80f5ea0fe668a23e0e0e7651dfe032e255af209f7ee6bacf6ed492d20154a8763fda469d99f6dc953066d6
Size (gearmand-1.0.6.tar.gz) = 935050 bytes
SHA1 (patch-Makefile.in) = ec857867640d5282dc9a06ab8258c82b8cb1ba55
SHA1 (gearmand-1.1.18.tar.gz) = eb7f1d806635cba309c40460c3ca5f2ff76d6519
RMD160 (gearmand-1.1.18.tar.gz) = 2bbe1042932dd763fcc68f4c8e6227d6a53be7e0
SHA512 (gearmand-1.1.18.tar.gz) = fd2c978775bde19a8f1ffaf720b4c8adfda9859e5f554b247e7edca15fcc684168fb279af6c63e29c0524c8c863a9f3d07ea802e67eec42be793c0487b9beb9a
Size (gearmand-1.1.18.tar.gz) = 1044664 bytes
SHA1 (patch-benchmark_blobslap__worker.cc) = 12f805d65b36a2f25e5751b8c36a95ac28ec757a
SHA1 (patch-configure) = d5eb9dc8bf6aec65580de30734e3e4b6505cd0ae
SHA1 (patch-examples_reverse__client.cc) = 3e8a27626c8a922919adfddcd9b3b4bfec06390d
SHA1 (patch-examples_reverse__client__bg.cc) = 63db59b98a8128565cecaa682334be85edf37584
SHA1 (patch-examples_reverse__client__cb.cc) = 33f9710ca20101ce11cda04407eff1e05b14d29a
SHA1 (patch-examples_reverse__client__epoch.cc) = e4ea3dc00f9fc403a5500d95591255c0990da6d3
SHA1 (patch-libgearman-1.0_gearman.h) = d97a3078ababae57922bee92e6bdcd28a4fb1aae
SHA1 (patch-libgearman-server__log.cc) = ecad056d7704451bce88e889fc0f9ce528281223
SHA1 (patch-libgearman_backtrace.cc) = f8b643a91fb7d3656c10616fcd37a9dc0749904e
SHA1 (patch-libtest__exception.hpp) = 193ee0e3711272f99ee3594f8629e27d572ca116
Expand Down
104 changes: 0 additions & 104 deletions devel/gearmand/patches/patch-Makefile.in

This file was deleted.

18 changes: 0 additions & 18 deletions devel/gearmand/patches/patch-libgearman-1.0_gearman.h

This file was deleted.

0 comments on commit b6702b8

Please sign in to comment.