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1 Basics

1.1 Input Devices

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Key Customize hot keys You can limit the area where a hot key is effective:
• "All": TE window (file lists, folder trees and bars)
• "List": File list
• "Tree": Folder tree
• "Edit": Rename text box
• "Menus": Folder Menu

key.xml 1.26
2021/12/4

˄ Mouse Customize mouse gestures You can limit the area where a mouse gesture is effective:
• "All": TE window (followings and bars)
• "List": File list and file list background
• "List(Background)": File list background
• "Tree": Folder tree
• "Tabs": Tab and tabs background
• "Tabs(Background)": Tabs background

mouse.xml 1.33
2021/12/13

Long press Enable "long press" as a mouse gesture, which is 
common in touch screen devices

• You can customize the elapsed time to press. The default is 500
milliseconds (half a second).

• Mouse gesture input window of other add-ons cannot detect a 
"long press". Type in the mouse gesture code 1- instead.

1.03
2021/12/25

Gesture priority 
plus

Under a "double-click to open an item" 
environment, when you use a right button gesture
• on a selected item: it becomes a right button 

drag-and-drop.
• on an unselected item: it remains a right button 

gesture.

Compared with "Gestures" setting in "Tools > Options > General > 
Mouse":
• "Normal": always a right button drag-and-drop
• "Priority": always a right button gesture

1.01
2020/12/21

1.2 Menus

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Main menu Main menu bar To customize the menu:
• Choose "Tools > Options > Menus", and/or
• Use "Menu item filter" add-on

1.16
2021/8/17

1 Main menu button Show the main menu by:
• Command button
• Alt key

To change the menu bar to a button:
1. Enable this add-on
2. Disable "Main menu" add-on

{BKGT} 1.17
2022/1/12

Quicker menu 
display

Show a simplified menu when you right-click a file 
list or a folder tree, or choose the File menu.

• Choose "Default" to show the original menu.
• Not applicable to special folders

1.17
2022/1/15

Menu item filter Remove certain menu options based on the 
criteria you specified. Use this add-on to remove 
any menu option that cannot be removed using 
"Tools > Options > Menus".

• Options (see Appendix A for the pattern format)
▪ "Path": Optionally specify a folder for which removal is 

effective. A folder path pattern can also be specified.
▪ "Filter": Specify a menu option by its name or in a pattern.

• To skip the removal, keep Shift key pressed when you bring up 
a menu.

• To remove a whole menu from menu bar, use User style sheet:
#MenuMenuName { display: none; }

menuitemfilter.tsv 1.06
2022/1/6



1.3 Tool Bars

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Tool bar Custom tool bars
• Click an item: Open / run the item
• Ctrl+Click or middle-click an item: Open the item

in a new tab
• Right-click an item: Go to Options page
• Click + button: Go to Options page
• Drop to + button: Add the dragged sources as 

buttons

• Drag a source and drop it to an item of Type
▪ Open: File copy/move the source to the item.
▪ Exec: Run the item with the source replacing %Selected%.
▪ Selected items: Run the item with the source plus selection.

toolbar.xml 1.44#
2022/3/31

Link bar Custom tool bars with optional button names
• Click an item: Open / run the item
• Ctrl+Click or middle-click an item: Open the item

in a new tab
• Right-click an item: Go to Options page
• Click + button: Go to Options page
• Drop to + button: Add the dragged sources as 

buttons

• Drag a source and drop it to an item of Type
▪ Open: File copy/move the source to the item.
▪ Exec: Run the item with the source replacing %Selected%.
▪ Selected items: Run the item with the source plus selection.

• Click ▼ to show a Folder Menu of the item.
▪ Opt out "Buttons" to hide and disable this button.

• If you add a button of a system folder by drag-and-drop, its path 
will be in system format. Choose "Normal" for a local name.

linkbar.xml 1.33#
2022/3/30

Simple Tool bar Tool bar of 5 buttons: back, forward, up, new tab 
and refresh.

Its functions can be achieved by individual add-ons which can be 
customized and have more functions.

1.06
2021/2/19

1 Quick notes Command button to show a custom menu of 
commands with hot keys enabled

Options:
• Click Browse button to choose a hot key, then amend the 

command name if necessary.
• Enter -, // or / to name for a separator line or a columun break.

quicknotes.tsv 1.02#
2023/1/17

2 From Start to End

2.1 Navigation

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄
2

Address bar Breadcrumbs address bar
• Click a folder name: Go to the folder
• Ctrl+Click or middle-click a folder name: Open 

the folder in a new tab
• Right-click a folder name: Show a menu to:

▪ Copy the folder to Windows Clipboard
▪ Copy the folder path to Windows Clipboard

• Click ►: Show a menu of sub-folders
• Click ▼: Show a menu of folder tree top items
• Ctrl+Enter: Open an input path in a new tab.
• Shift+Enter: Open the parent folder of an input 

path in a new tab.

• Drag the icon or a folder name and drop it somewhere: Drag-
and-drop the folder. Default as shortcut.

• Drop to a folder name: File copy/move the dragged source
• « appears when an address is too long. Click it to show a menu 

of ascendant folders.
• See Folder Menu Features.
• You can enter commands through address bar similarly to the 

Windows Run dialog box.
• Enter javascript:command to run a JScript command.
• To change to classic style, opt for "XP style".

{bMKGT} 1.75#
2024/12/9

˄
2

Back Command button to go backwards in history
• Click: Go to last visited folder
• Right-click: Show a menu of visited folders

• Shift+Right-Click to show item paths on the menu.
• Ctrl+Click the button or a menu option to open the target in a 

new tab.

1.18#
2021/8/17

˄
2

Forward Command button to go forwards in history
• Click: Go to next folder in history
• Right-click: Show a menu of forward folders

• Shift+Right-Click to show item paths on the menu.
• Ctrl+Click the button or a menu option to open the target in a 

new tab.

1.18#
2021/8/17



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄
1
2

Up Command button to go upwards in folder tree
• Click: Go to parent folder (or searched folder, if 

the tab is a result list)
• Right-click: Show a menu of ascendant folders

• Ctrl+Click the button or a menu option to open the target in a 
new tab

• See Folder Menu Features.

{BMKG} 1.20
2021/8/17

Set home Tab context command to set the current folder as 
the home location of a tab

{MKGT} 1.04
2022/2/16

Go home Tab context command to go to the home location 
of a tab

{MKGT} Set home 1.04
2022/2/16

Go home 
automatically

Automatically go to the home location when the 
tab becomes inactive or invisible

A tab becomes invisible upon tab switching or workspace (tab 
group) switching.

Set home 1.00
2023/1/26

Drive bar Tool bar of drive buttons
• Click: Open the root folder in a new tab
• Right-click: Context menu of the drive

• TE can refresh the drive bar automatically when any drive is 
added or removed.

• Options (see Appendix A for the pattern format)
▪ "Filter": Show drives with root paths matching this pattern.
▪ "Disable": Hide drives with root paths matching this pattern.

1.19
2024/3/3

1 Drive button Command button to show a menu of drives • Right-click to show the context menu of "Computer". You can 
connect to or disconnect from a network drive using the menu.

• See Folder Menu Features.

{BMKGT} 1.11
2021/4/3

˄
1

Undo close tab Re-open the tab last closed by:
• Tab context command
• Ctrl+Shift+T
• Middle-click tab background

• The browsing history of a tab can be recovered together.
• You can customize the maximum number of tabs to record. The 

default is 30.

closedtabs.xml
{BMKGT}

1.18
2024/9/23

1 Recently closed 
tabs

Show a menu of recently closed tabs for re-
opening by:
• Command button
• Tab context menu

You also can right-click "Undo close tab" button to show the menu,
if you configure that as such.

{BMKGT} Undo close tab 1.11
2024/5/27

1 History Show a list of recently opened folders in a tab by:
• Command button
• Ctrl+H

You can customize the maximum number of folders to record. The 
default is 1000.

history.tsv
{BMKGT}

1.20
2022/1/27

Speed dial Show a list of most frequently opened folders (a 
maximum of 10) when you add a tab

• This list will become the default new tab. If you do not want this 
change, opt out "New tab".

• Opt for "Menus" if you want to choose this list (about:newtab) 
from ▼ menu of address bar.

speeddial.tsv 1.15
2022/1/26

˄ Blank page Fill the blank tab (about:blank) with a predefined 
list of items ("Computer", user folders and drives)

The blank tab replaces "Desktop" as the initial tab when TE starts 
up the first time, starting from TE 21.4.5.

1.04
2022/1/27

Simple Address 
bar

Text-only address bar
• Ctrl+Enter: Open an input path in a new tab.
• Shift+Enter: Open the parent folder of an input 

path in a new tab.

• You can enter commands through address bar similarly to the 
Windows Run dialog box.

• Enter javascript:command to run a JScript command.

{bMKGT} 1.14#
2021/4/5

Entered history When you click ▼ of an address bar, show a 
menu of folders you have visited by entering 
folder addresses.

You can input "entered:" to an address bar to show the history in a
tab for manipulation.

enteredhistory.tsv Address bar (or its
"Inner" version)

1.05
2022/1/27

Navigation sound Emit a sound when you navigate, like Windows 
Explorer

Only WAV file is supported. 1.02
2020/12/27



2.2 Folder View

Note: "Remember folder view settings", "Take over folder view settings" and "Folder settings" may interfere each other. Usually only one of them can be enabled anytime.
However, you can use "Take over folder view settings" or "Folder settings" to set up default views, and use "Remember folder view settings" together (place it above the former) to keep individual views.

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Remember folder 
view settings

Remember the view of each folder when you 
navigate and apply it when you re-visit the folder, 
like the default behavior of Windows.

• You can customize the maximum number of folders to 
remember. The default is 1000.

• Options (see Appendix A for the pattern format)
▪ "Filter" / "Disable": Remember / Forget the view when a folder 

path matches this pattern.

remember.xml 1.42
2021/12/23

About remember Manage the folder views stored with "Remember 
folder view settings" add-on

• To open the list, choose it from ▼ menu of address bar (you 
must have opted for "Menus"), or navigate to "about:remember".

• To see or edit a folder view:
▪ click the item on the list, or
▪ select the item and press Enter key, or choose "Edit" context 

command
• To remove folder views, select the items and press Delete key, 

or choose "Remove" context command.

Remember folder 
view settings

1.07#
2022/1/27

Folder settings Apply a specific view to a folder based on folder 
path pattern when you navigate. You can specify a
list of rules which is checked from bottom 
upwards, and the first match wins.

• TE may unexpectedly change the view when you navigate. This 
add-on tells TE to adhere to the rules you specified.

• Steps to use:
1. Customize the view to your need

▪ choose a view mode (icon, list, details, etc.)
▪ choose columns (from "View > Choose Details" dialog box)
▪ adjust the position and the width of each column
▪ group and/or sort the items if needed

2. Choose "View > Customize folder"
▪ click "Get the current folder view"
▪ change "Filter" to a folder path pattern if necessary
▪ click "Add" or "Replace" accordingly

• You can change column widths in "FV.Columns" to -2 for auto fit.
• Filter format (see Appendix A):

▪ special folder is represented by a number
▪ query result list is represented as query:
▪ examples:

▫ Local and network file folders ?:\*;\\*\*
▫ Computer 17
▫ Recycle Bin 10
▫ Windows Search result list search-ms:*

• First set up the view for general file folders. Then set up the 
views for exceptions.

• To skip applying any view to an unusual folder (such as
C:\Windows\Fonts), set up a record with "Options" emptied.

foldersettings.xml 1.39
2022/1/16

Take over folder 
view settings

Remember the current view and apply it when you
navigate

• TE may unexpectedly change the view when you navigate. This 
add-on tells TE to adhere to the current view.

• Options (see Appendix A for the pattern format)
▪ "Filter": Enable when a folder path matches this pattern.
▪ "Disable": Disable when a folder path matches this pattern.
▪ "Lock": Lock into the view when this option is ticked. Any 

subsequent changes to the view will be dropped.

takeoverfoldersettings.txt 1.08
2020/12/17



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Copy folder 
settings

File list background context command to generate
"folder settings" into Windows Clipboard

{MKGT} 1.02
2022/1/16

1 Reset columns Apply the default column settings in Windows 
Explorer to the current folder

• Menu option: "File > Reset Columns"
• To remember the applied settings, use either "Remember folder 

view settings", "Take over folder view settings" or "Folder 
settings" add-on.

{BMKGT} 1.05
2021/4/2

Replace slow 
columns

Automatically replace the slow "Date" column with
the fast "Modified Date" column when you 
navigate, if the latter is not currently in the view.

Usually this add-on is not needed because the slow "Date" column
is not a default.

1.03
2020/12/15

Items count Show an item count in the Size column for each 
file folder in details view

The count will comply with "Show all files" option in "Tools > 
Options > List".

1.02
2021/8/29

˅ Space free 
column

Customize the unit of "Free Space" column in 
"Computer" system folder

For advanced users: If your file folder contains a directory 
symbolic link or a directory junction, you can choose "Free Space"
column from "View > Choose Details" dialog box to show that 
information of the linked drive.

1.02
2021/1/5

Path column Supply path, folder path, item type and item name
column values to result lists.

You can customize the result lists to support by specifying path 
patterns (see Appendix A).

1.02#
2022/1/25

Explorer browser 
filter

Automatically switch to "Explorer browser" engine 
when the folder path matches a specified pattern

• To get a "*\folder name" pattern from a folder selection window, 
keep Shift key pressed when you click the Open button.

• See Appendix A for folder path pattern format.

1.01
2021/1/6

2.3 Work with Folders

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1
2

Refresh Command button to refresh current file list 1.10
2021/8/20

Force refresh Automatically refresh a file list
• after a file operation (result lists excluded)
• when you switch to a tab (any file list)

• You can specify where this add-on will work (see Appendix A):
▪ "Filter": The folder path must match this pattern.
▪ "Disable": The folder path must not match this pattern.

• Switching pane will NOT trigger any refresh.

1.11#
2024/5/1

1 Switch hidden 
items

Show or hide items with hidden attributes in 
current file list

You can see the current state on button face or menu option. {BMKGT} 1.05#
2021/4/4

1 Switch hidden 
filter

Show or hide items with names matching "Tools > 
Options > List > Filter" in current file list

Menu option: "View > Switch hidden filter" {BMKGT} 1.03
2021/12/15

1 Flat Tab context command to show all items under a 
folder branch as a flat list. File folder and clip 
folder are supported.

• Opt for "Compressed Files" to expand any archive file, such as 
ZIP and CAB, too.

• This add-on also works on a Badge / Label search result list.

{BMKGT} 1.23#
2022/2/23

Right key next Comply the usage of left/right keys in icon and tile 
views with Windows Explorer: pressing left/right 
key always goes to the previous/next item.

Without this add-on, TE stops at the leftmost/rightmost item and 
does not go up/down when you press the left/right key 
continuously in icon and tile views.

1.05
2021/5/3

Down key next Comply the usage of up/down keys in icon and tile
views with list view: pressing up/down key always 
goes to the previous/next item.

This add-on is useful only when "Align left" in "Tools > Options > 
List > Style > Advanced" is opted for.

1.00
2021/5/3



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Between files and 
folders

Jump to the nearest file if the current item is a 
folder, and vice versa.

• Menu option "Edit > Between files and folders"
• This add-on does not work on an unsorted or mix-sorted file list.

{MKGT} 1.01#
2021/8/18

Regular 
Expression/
Migemo 
Incremental 
Search

Enhance the built-in "type to jump" function so that
you can jump to an item with its name:
• containing the input keys, or
• matching the input keys as a regular expression

(/ is not needed)

• Press PageUp / PageDown to jump to prior/next matching item
• If C/Migemo add-on is enabled, the input keys are automatically 

converted to a regular expression for Japanese matching.
• Use Status bar to see your input keys
• You may need to remove some default hot keys such as Shift+6 

(^) and Shift+4 ($) which conflict with regular expression.

1.09
2021/12/27

Show focused 
item frame

Always show a focus rectangle around the 
focused item when a file list gets the focus

Without this add-on, focus rectangle may be hidden after 
navigation or refresh.

1.02
2021/10/13

Fix Single click 
activate

Speed up "single-click to open an item" by 
removing an unnecessary delay after you click an 
item in a file list

You must also opt for "Single click activate" in "Tools > Options > 
List > Style". If you have any saved workspace, you have to opt for
it in each workspace.

1.03
2020/12/4

2.4 Sort

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1

˅
Mixed sort Command button to sort files and folders together 

(Windows Explorer sorts them separately). You 
can sort by name or modified date, in ascending 
or descending order.

• You can also sort with Shift+Click "Name" or "Modified Date" 
column heading.

• You can use it as an initial sort with Folder settings add-on.

{BMKGT} 1.13
2021/4/5

1

˅
Total file size sort Command button to sort all items by "Total File 

Size" in descending order, and display the column
if not yet.

• "Total File Size" is:
▪ for a folder: total size of all files under the folder branch
▪ for a file: same as its size

• You can also sort with Shift+Click "Size" column heading.
• You can use it as an initial sort with Folder settings add-on.

{BMKGT} 1.13
2021/12/15

1

˅
Reset sort 
columns

Change a sorted file list to unsorted • Menu option: "File > Reset sort columns"
• Choose this menu option when you set up a folder view record 

for a result list, so that the result list can show faster without an 
initial sort.

{BMKGT} 1.05
2021/12/15

2.5 Filter

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄
2

Filter bar 1. Filter a file list with a name filter
(see Appendix A)

2. Start and refine an automatic Windows Search

• Start a Windows Search by pressing Shift+Enter or Ctrl+Enter.
• You can drag-and-drop files/folders to the bar to filter or search 

for item names. Hold Shift or Ctrl key down for searching.
• Up / Down arrow key: Switch to file list.

{bMKGT} 1.39#
2022/1/30

1 Filter button Command button to
• input a name filter for a file list, or
• refine a Windows Search

See Appendix A for filter format {BMKGT} 1.10
2021/5/26

Filter list Show a menu of user-defined name filters
• Click / right-click filter icon of filter bar
• Right-click filter button

• To edit user-defined name filters:
▪ Shift+Ctrl+Click / Shift+Ctrl+RightClick filter icon of filter bar
▪ Shift+Ctrl+RightClick filter button

• You can opt to show only "Name" or "Filter" column in the menu.

filterlist.tsv Filter bar,
Filter button or
Inner Filter bar

1.07
2021/5/26



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Folder filter Let you specify ".folder" to filter for folders, as if it 
were a file name extension.

Folder types include file folder, drive, system folder, network 
computer, network share and library.

Filter bar,
Filter button or
Inner Filter bar

1.00
2021/5/12

Clear filter with 
"Up"

If there is a name filter, going up (clicking Up 
button, Alt+Up, etc.) will become clearing the filter.

Use this add-on to keep the feature provided by TE version 20.5.9 
and before.

1.04
2021/8/18

2.6 Search

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

2 Search bar File/folder search using Windows Search • Refine your input to search the same folder again
• Clear the bar and click it to go back to the searched folder

{bMKGT} 1.12
2021/12/14

Everything File/folder search using Everything • You can control your search scope by an option and the key 
pressed to start a search:
"Subfolders" Start by Search scope
Not ticked Enter All
Not ticked Shift+Enter Current folder branch
Ticked Enter Current folder branch
Ticked Shift+Enter All

• Specify regex: to search with a regular expression
• You can customize the maximum number of items in a search 

result. The default is 1000.

{bMKGT} [Everything] 1.46
2023/9/12

1 Find files Search a folder or a clip folder by partial file name 
(accept wildcards) and/or by text contents (case 
insensitive)

• Default hot key is F3
• Search for files only. Folders are excluded.
• This add-on also works on a Badge / Label search result list.
• See Appendix A for input file name format

{BMKGT} 1.19#
2021/4/5

1 Information 
search

Search a folder or a clip folder by file name 
(accept wildcards) and/or by file information

• Default hot key is Shift+F3
• Search for files only. Folders are excluded.
• This add-on also works on a Badge / Label search result list.
• See Appendix A for input file name format

{BMKGT} 1.03#
2021/4/3

1 Search by date 
modified

Search current folder for items with modified date 
in a range you choose using Windows Search

{BMKG} 1.04
2021/12/18

1 Search by size Search current folder for items with size in a range
you choose using Windows Search

{BMKG} 1.04
2021/12/18

1 Empty folder Search for empty folders under the branch of:
• current folder (when no item is selected), or
• selected folder
then list the result in a new tab

You can then permanently delete any selected items using a 
context command. TE will ask you to confirm before the operation.

{BMKGT} 1.19#
2021/5/3

2.7 Select

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Wildcard selection Select items with names matching an input 
pattern (wildcard format or regular expression)

• Menu option: "Edit > Wildcard selection"
• See Appendix A for input pattern format

{MKGT} 1.05
2021/1/13

https://www.voidtools.com/


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Select nonexistent
items

Select any non-existent item • Menu option: "Edit > Select nonexistent items"
• Such item may appear in a file list provided by History, Speed 

dial, Entered history, Badge, Label and Clip folder add-ons, after
it is renamed, moved or deleted.

{MKGT} 1.03
2021/1/13

Save selected 
items

Command button to save your selection from a file
folder so that you can re-select them later on

• You also can drag-and-drop a saved selection using the button.
• Selection in other kinds of file list will not be kept when TE exits.

saveselection.tsv 1.07
2022/3/2

Remember 
selection

Remember your selection in each file folder when 
you navigate and automatically select them when 
you re-visit the folder

• You can customize the maximum number of folders to 
remember. The default is 1000.

• When you go up, TE will still select the folder you are from.
• Selection in other kinds of file list will not be kept when TE exits.

rememberselection.tsv 1.04
2022/1/25

Select first After navigation, select the first item on file list, if 
there is not any other default selection.

1.00
2024/11/1

Select plus Automatically select the items in the destination 
folder after drag-and-drop or cut/copy-and-paste

1.04
2021/1/16

Check box Use check boxes to select items • If you opt for "All":
▪ You can click an unselected item without pressing Ctrl to add 

it to your selection, when 2 or more items have been selected.
▪ Opt for "Background" to prevent yourself from mistakenly 

deselecting a multiple selection by clicking file list background.
Use double-click to deselect.

• Opt for "XP style" to use the traditional style.
▪ It works well only under a "double-click to open" environment.
▪ It does not work in small icon view on Windows 7.

• You may need to restart TE after you have changed any option.
• "Use check boxes to select items" option in Windows Control 

Panel > Folder Options has no effect in TE.

1.13
2021/6/26

shift key to select 
in X-Finder style

Expand selection range from focused item if you 
select with Shift key kept pressed

Without this add-on, selection range is expanded from firstly 
selected item, like Windows Explorer.

1.01
2021/10/2

Selected to top Move your selection to the top of the file list • Menu option: "Edit > Selected to top"
• This add-on does not work under "Explorer browser".

{MKGT} 1.00
2021/4/14

Full row select 
plus

To ease both mouse and keyboard control, 
disable "full row selection" when the mouse 
pointer is in a file list, and enable it otherwise.

TE has a problem in displaying focus rectangle in file lists and 
hinders keyboard control. A work around is "full row selection" 
which hinders mouse control. This add-on eases both.

1.01
2020/12/19

Classic style Display selection in classic style (white text on 
blue background) instead of default style (light 
blue box)

If you use a Windows classic theme, you do not need this add-on 
since any selection is already displayed in classic style.

1.10
2021/4/8

Disable classic 
style during drag

Apply "Classic style" except when you drag a 
selection within a file list

Classic style 1.02
2020/12/21

Order of Selected 
items

Ensure a custom menu option or an add-on will 
process selected items in the current sequence in 
a file list

• You can specify your selection in two ways:
▪ Implicitly: Choose "Selected items" in "Type" drop-down box
▪ Explicitly: Specify %selected% after a program in "Options" 

box
• Starting from TE 20.6.17, you can opt for "Process selected 

items in view sequence" in "Tools > Options > List > Style" to 
achieve the same result without this add-on.

1.02
2020/6/17



2.8 Status Bars

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Status bar 1. Display either item count or selection count
2. Display help text for certain menu options
3. Display keystrokes when you "type to jump" in 

a file list

You can opt to display on the title bar. Then you also need to 
disable Title bar add-on.

1.19
2021/12/12

1 Count bar Display both item count and selection count You can opt to display on the title bar. Then you also need to 
disable Title bar add-on.

1.12
2021/12/10

1 Size status bar Display
• total size of selected files
• available drive space

• If you opt for "Folder", the size of any selected folder is included.
You may need to wait for a while if the folder stores many items.

• If you opt for "Total file size", this add-on works as if all files was 
selected when no item is selected.

• If you opt for "Free space":
▪ This add-on displays the available drive space at the actual 

location of the current tab as default.
▪ "Total file size" option is ignored.

• The size of a folder in a ZIP file cannot be displayed.

1.27
2022/2/18

Full path bar Display the full path of:
• current folder (when no item is selected), or
• last selected item in a file list, or
• selected item on a Folder Menu

• You can opt to display on the title bar. Then you also need to 
disable Title bar add-on.

• Opt out "Selected items" to ignore any selection on any file list.

1.07
2024/3/9

2.9 Clipboard

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Cut Command button to cut selected items to 
Windows Clipboard

{BMKG} 1.05
2021/12/15

1 Copy Command button to copy selected items to 
Windows Clipboard

{BMKG} 1.05
2021/12/15

1 Paste Command button to paste all items in Windows 
Clipboard to the current folder

{BMKG} 1.07
2022/12/6

1

˅
Paste as link Command button to paste all items in Windows 

Clipboard to the current folder as symbolic links 
(with absolute or relative paths) or junctions

TE will request for administrator privilege for the creation of EACH 
link. If you have many links to create, run TE with administrator 
privilege.

{BMKG} 1.06
2022/12/7

Clipboard Command button of clipboard operations
• Click: Show an action menu (cut, copy and 

paste) with paste source
• Drop to the button: Copy the dropped items
• Shift+Drop to the button: Cut the dropped items
• Drag the button and drop it somewhere: Paste 

the items from Windows Clipboard
• Right-click: Show a context menu of the items in

Windows Clipboard

"Paste source" includes:
• whether the source items are cut or copied, and
• the item names

1.09
2021/5/8



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Clipboard history Record a few cut and copy operations, and let you
choose which to paste using a context menu.

• Steps to use:
1. Do a few cut and copy operations.
2. Right-click file list background of the destination folder.
3. Choose the source to paste.
4. Choose to copy, move or create shortcut.

• You can customize the maximum number of cut and copy 
operations to record. The default is 15.

{MKGT} 1.08
2021/12/20

Order of clipboard Ensure any cut or copied items will be pasted in 
the current sequence in a file list

Without this add-on, the process sequence is not assured. 1.00
2021/8/13

Clipboard copy Let you paste the full paths of any copied items to 
another application

In the same format as environment variable %Selected%, i.e. may
be in quotes and multiple items in one line.

1.06
2020/12/8

Clipboard image Let you save an image in Windows Clipboard by 
pasting it to a file list

1.01
2020/11/21

2.10 File Operations

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Duplicate copy 1. Let you specify the item name when you 
duplicate an item in a folder

2. Let you confirm when you duplicate multiple 
items in a folder

You can duplicate selected items by a menu option, a command 
button, a hot key or a mouse gesture if you configure this add-on 
as such.

{BMKGT} 1.11
2021/4/3

Move content up Context command to move all items in the 
selected folders to the current folder

TE will ask you to confirm before the operation. The emptied 
folders will be moved to Recycle Bin. Keep Shift key pressed 
when you confirm to delete the emptied folders permanently.

{MKGT} 1.02
2020/12/10

Rename dialog 
box

Show a dialog box to rename an item when you 
press F2

It also lets you change drive volume labels, certain system folder 
names and library names.

{MKGT} 1.05
2021/1/11

Rename dialog 
plus

Show a dialog box to rename an item (with 
extension in a separated field) when you press F2

It also lets you change drive volume labels, certain system folder 
names and library names.

{MKGT} 1.09
2024/2/12

Toggle selection 
while inline 
renaming

When you press F2 key to rename an item, the file
name is selected. This add-on lets you press F2 
key again to select the extension and then the 
whole item name.

This add-on is useful when "Hide extensions for known file types" 
option in Windows Control Panel > Folder Options is opted out.

1.00
2022/1/7

Fix selection on 
renaming

Default to keep file name extension when you 
rename an item in a result list

To comply with the behavior when you rename an item in a folder 1.03
2020/12/23

No edit labels Disable rename operation in any file list You can still rename an item with Properties page. 1.02
2021/1/10

1 Escape Unicode Command button to check and rename any item 
in the current folder for Unicode characters
• Escape: Rename away from Unicode
• Unescape: Reverse the renaming

• TE will ask you to confirm the new names before the operation.
• Useful if you have trouble accessing these items, especially 

when you transfer them to a different file system that does not 
support Unicode.

{BMKGT} 1.07
2021/12/15

1 Delete Command button to delete selected items
• Click: Move to Recycle Bin
• Shift+Click: Delete permanently
• Right-click: Context menu of Recycle Bin

• TE will ask you to confirm before any deletion.
• With certain result lists, items will be removed, not be deleted.
• You can drop items (in folders or result lists) to the button to 

delete, but there will not be any confirmation.

{BMKG} 1.07
2021/12/9



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Empty recycle bin File menu option to empty Recycle Bin • Windows will ask you to confirm before the operation.
• Right-click to show the context menu of Recycle Bin, if you 

configure this add-on as a command button.

{BMKGT} 1.06
2021/12/9

Virtual recycle bin Move the item to an automatically created "recycle
bin" folder when you delete it from a removable 
drive or a network drive. This is useful because 
such drive does not support Windows Recycle 
Bin, and any item deletion is usually permanent.

• You can open the "recycle bin" folder in a new tab by a context 
command from any file list background of the drive.

• Any item deletion from the "recycle bin" folder is permanent.
• TE will ask you to confirm before any deletion.
• To empty all virtual recycle bins, use JScript 
Sync.VirtualRecycleBin.EmptyRecycleBin();

• You can customize the name of the "recycle bin" folder. You can 
even put the folder in another drive.

1.05
2021/12/26

2.11 File Information

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Properties Command button to show the properties page of
• the current folder (when no item is selected), or
• the selected items

{BMKG} 1.06
2021/4/2

Change file 
attributes

Context command to change the read-only, 
hidden, system and archive attributes of selected 
items

You can see the attributes of drives and items in ZIP files with this 
add-on.

{MKGT} 1.10
2021/12/25

Change the Date 
modified

Context command to change the "modified date 
and time" of selected items

The time you input may be rounded up to an even number due to 
a limitation in Windows file system.

{MKGT} 1.12
2021/12/26

Change the 
timestamp

Context command to change modified, created 
and last accessed date and time of selected items

The time you input may be rounded up to an even number due to 
a limitation in Windows file system.

{MKGT} 1.10
2021/12/26

Show hash Context command to calculate and show the hash
values of a selected file

{MKGT} 1.01
2022/6/5

Virtual name Context command to give a display name to an 
item in a file list, as if the item were renamed. You 
can also use this add-on to name a query item in 
a clip folder or a result list.

• Any operation on item name, such as filtering and sorting, is still 
based on real item name, not on display name.

• Display names show only when the folder path of a tab matches
"Filter" (see Appendix A), if the latter is specified.

virtualname.tsv
{MKGT}

1.07
2022/1/18

Extension tooltips 
changer

Let you choose the information in the tip pop-up 
(shown when you select or focus on an item in a 
file list) based on file type.

You can specify "folder" as if it were an extension. extensiontooltip.json 1.06
2022/2/9

No infotip Do not display any tip pop-up when you select or 
focus on an item in a file list, regardless of the 
state of "Show pop-up description for folder and 
desktop items" option in Windows Control Panel >
Folder Options.

Certain add-ons (such as Archives and Compounds) enable TE to 
show non-file-system items in a file list. A tip pop-up of a folder 
may show even when you have opted out the said control panel 
option. Use this add-on to solve the problem.

1.02
2021/4/8



3 Essentials

3.1 Folder Tree

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄
1

Tree view 1. Command button to toggle folder tree
2. Navigate with folder tree
3. Additional hot keys and mouse gestures:

• Tab key: Switch to file list
• Middle-click selection: Open in a new tab
• Double-click selection: Open the item

• "Expand folder": Expand the folder you navigate to.
• "List": Automatically switch selection to match current file list.
• "Collapse folder": Collapse the folder if you navigate upwards.
• "Refresh": Refresh the folder tree when a file list is refreshed.

{BMKGT} 1.48
2024/11/22

Side tree view Shared folder tree for all tabs and panes • "Expand folder": Expand the folder you navigate to.
• "List": Automatically switch selection to match current file list.
• "Collapse folder": Collapse the folder if you navigate upwards.
• "Refresh": Refresh the folder tree when a file list is refreshed.
• If you align Favorites bar and Side tree view at the same side, 

specify their heights in percentage, e.g. 30% for Favorites bar 
and 70% for Side tree view.

• To specify multiple tree roots, keep Ctrl key pressed when you 
click the Open button of the folder selection window.

• To toggle like regular Tree View, use Add-on switcher add-on.

1.33
2024/11/22

Disable Tree drop Disable drag-and-drop to the folder tree
1. from another tree node, and
2. from a file list, and
3. from another application

• "Disable Drag-and-Drop" option in "Tools > Options > Tree" can 
help case 1 only. Use this add-on to achieve all 3 cases.

• Drag from the folder tree to outside (to the tab background to 
open a folder, for example) is not affected.

1.04
2021/1/8

Tree view filter Hide items with paths matching specified patterns 
from folder trees

• To get a "*\folder name" pattern from a folder selection window, 
keep Shift key pressed when you click the OK or Open button.

• See Appendix A for folder path pattern format.

1.06
2021/3/1

3.2 Favorites

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Favorites Command button to show Favorites menu {BMKG} 1.06
2021/4/2

1 Add to favorites Command button to add current folder to 
Favorites

{BMKG} 1.07
2021/12/15

1 Add all tabs to 
favorites

Menu option to add all tabs of the active pane to 
Favorites as a group item

You can open multiple folders by one click to a group item. {BMKGT} 1.06
2021/12/15

Favorites Open in 
a New Tab

When you choose an item from Favorites menu, 
always open it in a new tab.

1.02
2021/1/20

1 Horizontal 
Favorites bar

Tool bar of Favorites
• Click an item: Open / run the item
• Ctrl+Click or middle-click an item: Open the item

in a new tab
• Right-click an item: Context menu
• Drop to empty space of the tool bar: Add the 

dragged source to Favorites

• Drag a source and drop it to an item of Type
▪ Open: File copy/move the source to the item.
▪ Exec: Run the item with the source replacing %Selected%.
▪ Selected items: Run the item with the source plus selection.

• Click ▼ to show a Folder Menu of the item.
▪ Opt out "Buttons" to hide and disable this button.

1.28#
2024/5/28



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Favorites bar Favorites pane showing one item on each line
• Click an item: Open / run the item
• Ctrl+Click or middle-click an item: Open the item

in a new tab
• Right-click an item: Context menu
• Drop to empty space of the pane: Add the 

dragged source to Favorites
• Drag and drop items inside the pane: 

Rearrange the items

• Drag a source and drop it to an item of Type
▪ Open: File copy/move the source to the item.
▪ Exec: Run the item with the source replacing %Selected%.
▪ Selected items: Run the item with the source plus selection.

• Opt for "Expanded" to automatically show all items in sub-
menus.

• If you align Favorites bar and Side tree view at the same side, 
specify their heights in percentage, e.g. 30% for Favorites bar 
and 70% for Side tree view.

1.44
2024/5/28

3.3 Tabs

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Tabs Tabs in classic style
• Let you operate by drag-and-drop with tabs, e.g.

open a folder, file copy/move and tab 
arrangement.

• Let you customize the appearance of tabs

• Drag a tab and drop it:
▪ to a storage: Default as folder shortcut
▪ to an application: Run the application with the folder

• Opt out "Open" under "Drag-and-Drop" to disable tab switching 
when you drag something over an inactive tab.

• Opt out "Drop to Folder" to disable file copy/move operations 
when you drop files/folders on a tab.

1.27
2024/2/18

˄ Tab plus Tabs in modern style
• Let you operate by drag-and-drop with tabs, e.g.

open a folder, file copy/move and tab 
arrangement.

• Let you opt for/out elements on tabs.
• Show Favorites menu when you move the 

mouse pointer on the + button, if you have 
enabled Favorites add-on.

• Drag a tab and drop it:
▪ to a storage: Not supported
▪ outside TE: Open the folder in Windows Explorer. The tab is 

then closed, unless you keep Ctrl key pressed.
• Opt for "Folder" under "Drag-and-Drop" to revert the above to 

the behavior of "Tabs" add-on.
• Opt out "Open" under "Drag-and-Drop" to disable tab switching 

when you drag something over an inactive tab.
• Opt out "Drop to Folder" to disable file copy/move operations 

when you drop files/folders on a tab.
• Opt for "Background" to highlight tabs background of active 

pane. Use User style sheet add-on to specify a color:
.activecaption { background-color: #code; }

Protect tabs 
(optional)

1.97#
2024/2/16

Change tab color Context command to set a tab color to a folder To reset the color, click "Cancel" in Windows Color Palette. tabcolor.xml
{MKGT}

Tab plus 1.09
2021/12/20

Tab color plus Display a tab with specific background and text 
colors when the folder path matches a specific 
pattern

• Literal match takes precedence.
• Then pattern matching on the list is from top downwards.
• See Appendix A for folder path pattern format.

tabcolorplus.tsv Tab plus 1.07
2022/4/27

Tab drive name Display drive letter additionally on tab Cannot be used together with "Tab parent folder name" add-on 1.05
2020/12/20

Tab parent folder 
name

Display parent folder name additionally on tab Cannot be used together with "Tab drive name" add-on 1.02
2020/12/14

Change tab name Context command to set a tab name to a folder To reset a tab name, delete it from the input dialog box. tabname.xml
{MKGT}

1.09
2022/1/18

Fixed tab name Context command to set a fixed name to a tab 
regardless of folder

To reset a tab name, delete it from the input dialog box. {MKGT} 1.00
2022/1/18



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Tab position 1. Designate the position of a new tab
2. Designate a tab to become current when you 

close the current tab

1.10
2021/12/20

Locked tabs top Automatically arrange all locked tabs together at 
the left

If you use "Sort tabs" add-on together, locked tabs and unlocked 
tabs will be separately sorted.

1.08
2021/4/10

Sort tabs Context command to sort the tabs in a pane by full
path (System) or by tab name

• Opt for "Auto" to automatically sort when you navigate.
• If you use "Locked tabs top" add-on together, locked tabs and 

unlocked tabs will be separately sorted.

{MKGT} 1.04
2021/5/6

Tab list List the tabs in all panes in a window
• Click an item: Switch to the tab
• Right-click an item: Tab context menu

• You can toggle the window by:
▪ Command button
▪ Menu option: "View > Tab list"

• You can filter (see Appendix A) the list by folder name.

tablist.json
{BMKGT}

1.04
2022/2/24

Recently used 
tabs

Show a menu of the tabs in the active pane in use
time sequence, then switch to a chosen tab.

Suggest you to configure this add-on as a hot key. {KGT} 1.02
2021/1/8

Select tab Switch to the tab with folder path specified as 
"Options"

You must have opened the folder in the active pane. {T} 1.01
2020/12/21

1 New tab Command button to add a tab 1.08
2021/12/15

New tab on 
forward

If you go forward with a tab without any forward 
page, add a tab.

1.00
2021/4/22

Close on back If you go back with a tab without any backward 
page, close the tab.

1.00
2021/4/22

Close all tabs Close all unlocked tabs in all workspaces Example – add a tool bar button to close all unlocked tabs:
• Name: Close all
• Type: Add-ons
• Options: Close all tabs (click Browse… to choose)

{T} 1.00
2020/2/6

Close tab when 
deleting

Close a tab automatically when the folder is 
deleted, unless the tab is locked.

You can opt for automatic closing for 3 more situations: storage 
media ejected, drive removed and network resource unavailable.

1.03#
2020/12/17

1 Close duplicate 
tabs

Context command to close any duplicated tab in a
pane, unless the tab is locked.

{BMKGT} 1.07
2021/4/2

Prevent duplicate 
tabs

When you go to a folder that is already opened in 
a tab in the active pane:
• If you request for a new tab, or the existing tab 

is locked, switch to that tab.
• Otherwise, that tab will be closed, and the folder

will be re-opened in the current tab.

• Opt for "Filter" to ignore any tab with a name filter in effect
• "about:blank" becomes the default new tab, if none is specified 

in "Tools > Options > Tabs".

1.19
2021/12/21

Open the same 
locked tab instead

When you go to a folder that is already opened in 
a locked tab in the active pane, switch to that tab.

• Opt for "Multiple panes" to cover inactive panes too.
• Opt out "Locked tabs only" to cover unlocked tabs too.
• Opt for "Skip tabs with filter" to ignore any tab with a name filter 

in effect.
• You can opt to close the current tab upon switching, if you do 

not request for a new tab.

1.11#
2020/11/29

Lock only disables
"Close tab"

Allow navigation with a locked tab 1.01
2021/2/10



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Protect tabs Context command to toggle tab closure. You can 
navigate with a protected tab but cannot close it.

Opt for "Protected" on "Tab plus" options page to show this status 
with an icon on a tab.

{MKGT} 1.07
2022/1/19

3.4 Panes

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Split 4 buttons to change workspace to a single pane, 2
panes (2 rows or 2 columns) or 4 panes (2 
columns × 2 rows)

• Upon split, TE will restore previously removed panes during un-
split. If you do not need any restoration, you can opt for "Close 
all tabs" so that the records used for restoration will not be kept.

• Upon un-split or workspace change, TE will keep panes starting 
from the first. The remainders will be removed (but with records 
kept). Opt out "Top/Left" so that TE will keep the active pane 
first.

• You can resize panes by dragging a pane edge with mouse.

1.26
2022/2/22

Split3 6 buttons to change workspace to 3 panes (3 
columns, 3 rows or 1 on left/right/top/bottom plus 
2 on right/left/bottom/top)

Split 1.12
2022/2/19

Split6 2 buttons to change workspace to 6 panes (3 
columns × 2 rows or 2 columns × 3 rows)

Split 1.10
2022/2/19

Split8 Command button to change workspace to 8 
panes (4 columns × 2 rows)

Split 1.04
2022/2/19

Split9 Command button to change workspace to 9 
panes (3 columns × 3 rows)

Split 1.04
2022/2/19

Split12 Command button to change workspace to 12 
panes (4 columns × 3 rows)

Split 1.00
2023/1/1

Switch to previous
pane

Switch to previous pane (go left then previous 
row)

Environment variable %PrevPane% contains the path of the 
current tab of previous pane.

{T} 1.03
2021/12/25

Switch to next 
pane

Switch to next pane (go right then next row) Environment variable %Other% contains the path of the current 
tab of next pane.

{T} 1.05
2021/12/25

1 Rotate pane Command button to swap all panes round {BMKGT} 1.03
2021/12/15

Inactive pane Change text and background colors of file lists 
and folder trees of all inactive panes so that the 
active pane can stand out

You can opt to color active pane instead. 1.11#
2021/12/19

1 Synchronize Command button to toggle synchronized browsing • When you navigate in a folder branch, the current tab of every 
other pane will follow if its branch has a similar structure.

• Opt for "Enabled" to automatically turn it on after startup or 
settings reloaded

{BMKGT} 1.06
2022/1/24

1 Sync select Compare the current tabs of two panes and select
items in 7 ways:
1. Select all items that are listed in the other pane.
2. Select all items that are only listed in this pane.
3. Select all matches that are newer.
4. Select all matches with a different size or 

modified date.
5. Select all items that are unique or newer.
6. Select all items that are unique or different.
7. Select all items that are selected in the other 

pane.

• You can toggle the function window by a command button or 
menu option "Edit > Sync select".

• Way 3 and 4: There is a tolerance of 2 seconds due to a 
limitation in Windows file system.

• Way 4 and 6: Size of a folder is the total size of all files under 
the folder branch. You may need to wait for a while if the folder 
stores many items. The title bar of the function window will show
a progress.

• If there is only one pane, current tab and its next tab will be 
compared.

syncselect.json
{BMKGT}

1.03#
2021/4/5



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Inner 
breadcrumbs 
address bar

Individual breadcrumbs address bar for each pane Position between "Internal Tool bar" and "Internal Tool bar Right" {bMKGT} 1.53
2024/8/12

Inner address bar Individual classic address bar for each pane Position between "Internal Tool bar" and "Internal Tool bar Right" {bMKGT} 1.35
2021/5/8

Inner Back Individual Back command button for each pane Position in "Internal Tool bar" 1.14
2021/12/13

Inner Forward Individual Forward command button for each pane Position in "Internal Tool bar" 1.16
2021/12/13

Inner Up Individual Up command button for each pane Position in "Internal Tool bar" 1.10
2021/12/13

Inner Refresh Individual Refresh command button for each pane Position in "Internal Tool bar" or "Internal Tool bar Right" 1.07
2021/12/13

Inner Filter bar Individual Filter bar for each pane Position in "Internal Tool bar Right" {bMKGT} 1.34
2022/1/30

Inner Search bar Individual Search bar for each pane Position in "Internal Tool bar Right" {bMKGT} 1.13
2021/11/25

Inner New folder Individual New Folder command button for each 
pane

Position in "Internal Tool bar" 1.06
2021/12/13

3.5 Workspaces

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Layout Command button to show a menu of layouts for 
loading

A layout includes all workspaces (tabs, panes and tab groups). {BMKGT} 1.02
2022/4/13

Tab groups A workspace (tab group) is a collection of of tabs 
and panes you work with. This add-on lets you 
open several workspaces at the same time, and 
switch among them by clicking the workspace 
tabs. TE saves all opened workspaces when it 
exits, and restores them when it starts.

• Each workspace can have its set of tabs and panes.
• You can save a workspace as a file and load it later.
• Mouse gestures on a workspace tab:

▪ Right-click: Context menu of workspace functions
▪ Double-click: Rename a workspace
▪ Wheel scroll: Switch the active workspace
▪ Drag-and-drop: Re-position a workspace tab
▪ Middle-click: Close a workspace

• You can drag-and-drop objects among workspaces. Opt out 
"Open" under "Drag-and-Drop" to disable this feature.

1.45
2021/12/26

1 Tab groups button Command button to manage workspaces Click the button to show a menu of your workspaces, then
• Choose an item: Switch to the workspace
• Right-click an item: Context menu

{BMKGT} Tab groups 1.02
2021/4/5



3.6 Frame Mode

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Show frames 
button

Command button to toggle Frame mode of a tab Under Frame mode, you can opt for Navigation Pane, Details 
Pane and Preview Pane.

1.04
2021/12/15

1 Frame plus Take control of panes under Frame mode
• Specify default states (visible or hidden)
• Toggle panes with buttons and hot keys
• Save and load states in layout / workspace files

1.04
2024/4/21

Frame pane Specify default states of panes and buttons under 
Frame mode
• "Default": Apply the last state (shared by TE and

Windows Explorer)
• "Visible": Always show
• "Hidden": Always hide

To reset existing tabs to default states, restart TE. 1.02
2020/12/29

3.7 Advanced Tools

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 Folder button Command button:
• Click: Show the address of the current folder 

and optionally open another folder as per input
• Right-click: Show a menu of sub-folders and 

parent folder of the current folder
• Drag the button and drop it somewhere: Drag-

and-drop the current folder. Default as shortcut.

• When the current tab is a query result or a Clip folder, the menu 
upon right-click shows all folders and query records in the file 
list.

• See Folder Menu Features.

{BMKGT} 1.11
2021/5/8

Hot button Show a button at the right of an item (a folder or a 
ZIP file) in a file list when you hover the mouse 
pointer on it. Click the button to show a menu of 
folder contents.

• When the hovered item is a query or a Clip folder, the menu 
shows a corresponding result list.

• When the hovered item is Windows Control Panel, the menu 
shows control panel items in category sub-menus.

• If you opt for "Select", any selection in the file list will be reset 
when you click the button, unless you keep Ctrl key pressed.

• See Folder Menu Features.

1.13
2022/1/20

Clip folder A clip folder is a storage in which you can put 
bookmarks of files, folders and queries. Then you 
can manage the items in it like a real folder. You 
can use a clip folder as:
• a clipboard to copy or move items from various 

locations to a single destination.
• an alternative to Favorites.

• Right-click file list background to create a clip folder.
• Click a clip folder to open it like a real folder.
• Use copy-and-paste or drag-and-drop to put files, folders and 

queries in a clip folder as bookmarks.
• Cut/copy-and-paste or drag-and-drop items from a clip folder to 

a real folder will become a file move/copy operation.
• Context command "Remove" and pressing Delete key will just 

remove a bookmark. The item itself will not be affected.
• You also can prepare a clip folder with any text editor. Save the 

CFU file in UTF-8 encoding with BOM.

{MKGT} 1.28
2022/3/4

NETSCAPE 
Bookmarks

Show a menu of bookmarks (exported from an 
application). The bookmark file must be a HTML 
file, and the first line must be:
<!DOCTYPE NETSCAPE-Bookmark-file-1>

Example – add a tool bar button to show a menu of bookmarks:
• Name: Bookmarks
• Type: NETSCAPE Bookmarks
• Options: (click Browse… to choose your bookmark file)
• Icon: (choose one you like)

{T} 1.06
2021/1/10



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Folder list 
menu

Show a menu of 
items listed in a 
text file

• You can prepare a menu as a text file with any text editor, and then use this add-on to open the menu.
• Example – add a hot key to open a folder list menu:

▪ Key: F12
▪ Type: Folder list menu
▪ Options: (click Browse… to choose your menu file)

• Save your menu file in UTF-8 or UTF-16 encoding with BOM in case of any Unicode character.
• Menu file format illustrated by examples:

Menu File Contents Case
C:\Windows Folder
%UserProfile% Folder (environment variable)
My documents %UserProfile%\Documents Folder with display name (format 1)
#EXTINF:-,My music
%UserProfile%\Music

Folder with display name (format 2)

- Separator line
Sub menu/My photos %UserProfile%\Pictures Folder under a sub-menu (format 1)
Sub menu/- - Sub-menu separator
#EXTINF:-,Sub menu/My videos
%UserProfile%\Videos

Folder under a sub-menu (format 2)

#EXTIMG:icon:general,17
Wallpapers findfiles:C:\Windows\Web\Wallpaper|*.jpg|

[icon: resource path]
Query

// Column break with separator
#EXTIMG:bitmap:ieframe.dll,697,24,9,16
TE `https://tablacus.github.io/explorer_en.html`

[icon: resource path, size 16]
Open a web site

#EXTIMG:...
C:\Windows\Media\flourish.mid

[icon: according to menu item type]
Open a file / application

#EXTIMG:C:\Windows\System32\notepad.exe
Edit `notepad %selected%`

[icon: from an EXE file]
Run an application (with a file)

/ Column break without separator
#EXTIMG:C:\Windows\Web\Wallpaper\Windows\img0.jpg,16
Hello javascript:alert("Hello")

[icon: from an image file, size 16]
Run a JScript command

 = a tab character

{T} 1.16
2024/7/28

3.8 Folder Menu

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Folder menu 
settings

Change the sort field and order of folder menus If you are held up by a lengthy menu frequently, you can use this 
add-on to turn off sorting.

1.02
2020/12/23

Folder menu filter Hide items with paths matching specified patterns 
from folder menus

• To get a "*\folder name" pattern, keep Shift key pressed
▪ when you choose an item from the Select menu
▪ when you click the Open button on a folder selection window

• See Appendix A for folder path pattern format.

1.04
2022/1/25



Folder Menu Features

• A "folder menu" lets you browse your computer storage with a menu and cascading sub-menus.
• 11 add-ons provide folder menus:

▪ Address bar  , Up button, Drive button, Folder button and their "Inner" versions: Show folders.
▪ Link bar  , Horizontal Favorites bar and Hot button: Show files and folders.
▪ Control Panel button  : Show control panel items in category sub-menus.

• Link bar  , Horizontal Favorites bar, Hot button and Folder button can show query results on the menu. Such queries include Clip folder, Label, Badge, History, Speed dial, Blank page, Entered history, 
About remember and Windows Search.

• Operations:
▪ Click an item: Open the item
▪ Ctrl+Click or middle-click an item: Open the folder in a new tab
▪ Right-click an item: Context menu
▪ Drag an item and drop it somewhere: Depends on the dropped location

• To show items with hidden attributes:
▪ Keep Shift key pressed when you bring up a menu, or
▪ Opt for "Include hidden items" in "Tools > Options > General"

• Preview  , Preview window, Preview in background, QuickLook, mpv and Full path bar add-ons also work on a selected item on a folder menu.
• Environment variable %MenuSelected% contains the path of selected item. It is available only in "Menus" of Key add-on.

Example Type Options

Run a program with selected item (menu stayed) Exec "C:\Windows\System32\mspaint.exe" %MenuSelected%

Run a program with selected item (menu closed) JScript / JavaScript let sCmd = ExtractMacro(te, '"C:\\Windows\\System32\\mspaint.exe" %MenuSelected%');
wsh.SendKeys("%{PrtSc}"); //Quit the menu by Alt key (PrtSc does nothing)
wsh.Exec(sCmd);

3.9 File Operation Helpers

Note: 1. Add-ons of this category may interfere each other. Usually only one of them can be enabled anytime.
2. You may fail if you copy or move an item from user's temporary folder. Opt out "Temporary Burn Folder" to solve the problem.

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Multi thread Use a separated thread for any file/folder 
copy/move/delete operation so that TE does not 
freeze during the operation

Right button drag-and-drop is not supported. To lift this restriction, 
use Right button drag-and-drop menu add-on together.

1.29
2022/1/24

Multi process Use a separated process for any file/folder 
copy/move/delete operation so that TE does not 
freeze during the operation

You can opt to play a sound when the operation finishes, if the 
operation lasts over a specific period. Windows Media Player may 
be required for certain audio file types.

Caution: with this add-on, FTP to TE may cause data loss.
FTP to Windows Explorer is OK.

1.37
2022/1/24

TeraCopy Use TeraCopy for any file/folder copy/move 
operation. TE will not freeze during the operation.

• If you install TeraCopy as a normal version:
▪ This add-on is NOT needed.
▪ Cut/copy-and-paste and drag-and-drop are fully supported.

• If you install TeraCopy as a portable version:
▪ This add-on is needed.
▪ Copy/move to TE (from TE / Windows Explorer) is supported, 

but copy/move to Windows Explorer (from TE) is not.
▪ Right button drag-and-drop is not supported.

• TeraCopy treats a HTML file and its associated FILES folder 
individually, but TE / Windows Explorer keeps them together.

[TeraCopy] 1.13
2022/1/24

https://www.codesector.com/teracopy


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

FastCopy Use FastCopy for any file/folder copy/move/delete
operation. TE will not freeze during the operation.

• Copy/move to TE (from TE / Windows Explorer) is supported, 
but copy/move to Windows Explorer (from TE) is not.

• To enable right button drag-and-drop, install "Shell Extension" of
FastCopy or use Right button drag-and-drop menu add-on.

• FastCopy treats a HTML file and its associated FILES folder 
individually, but TE / Windows Explorer keeps them together.

• To configure this add-on for use:
▪ Fill in the path of "FastCopy.exe"
▪ Click "Default" and opt for "Automatically start" under "Copy", 

"Move" and "Delete"

[FastCopy] 1.23
2022/1/24

Fire File Copy Use Fire File Copy (FFC) for any file/folder 
copy/move operation. TE will not freeze during the
operation.

• Copy/move to TE (from TE / Windows Explorer) is supported, 
but copy/move to Windows Explorer (from TE) is not.

• To enable right button drag-and-drop, run "setup_shell.exe" of 
FFC.

• FFC treats a HTML file and its associated FILES folder 
individually, but TE / Windows Explorer keeps them together.

• To configure this add-on for use, fill in the path of "ffc_shell.dll".
• This add-on works with TE32 only.

[Fire File Copy] 
(Japanese)

1.16
2022/1/24

4 File Processing

4.1 File Viewers

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Preview Display the contents of a selected / focused file in 
Preview pane. Text, image and media files are 
supported. You can also play a media file in the 
pane.

• "Height": Pane height in pixels, or - for auto-fit.
• You can customize the text and media types to support by 

specifying file name patterns (see Appendix A).
• You can adjust the upper "Limit" of text file size to support, and 

the "Size" (amount) of text to read and show.
• Windows Media Player may be required for certain media types.
• Opt out "Mouse" to ignore focus movement.

Image Producers 
(optional)

1.48
2024/3/22

1 Preview window Display the contents of a selected / focused file in 
Preview window. Text, image and media files are 
supported. You can also play a media file in the 
window.
You can toggle the window by:
• Command button
• Menu option "Edit > Preview window"

• Up / Left / Backspace key / Shift + Double-click: Prior item
• Down / Right / Enter key / Double-click: Next item
• You can customize the text and media types to support by 

specifying file name patterns (see Appendix A).
• You can adjust the upper "Limit" of text file size to support, and 

the "Size" (amount) of text to read and show.
• Windows Media Player may be required for certain media types.
• Opt out "Mouse" to ignore focus movement.

{BMKGT} Image Producers 
(optional)

1.33
2024/2/26

Tooltip preview Display the contents of a selected / focused file in 
a tip pop-up. Text, image and media files are 
supported.

• You can customize the text file types to support by specifying file
name patterns (see Appendix A).

• You can adjust the upper "Limit" of text file size to support, and 
the "Size" (amount) of text to read and show.

• Opt for "Folder" if you want folder previews.
• Opt for "Only Allow: Selected items" to ignore focus movement.
• Cannot be used together with No infotip add-on.

Image Producers 
(optional)

1.28
2024/2/28

https://freesoft-100.com/review/fire-file-copy.php
https://fastcopy.jp/en/


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Preview in 
background

Display the contents of a selected / focused file on
file list background. Image and media files are 
supported. You can toggle this function by:
• Command button
• Menu option "Edit > Preview in background"

• "Visible": Turn this function on after TE startup or settings 
reloaded.

• "Size": Maximum width or height of a preview.
• "Limits": Maximum file size to support.
• Opt out "Mouse" to ignore focus movement.

{BMKGT} Image Producers 
(optional)

1.12#
2024/12/22

Menu image List selected image and media files in a context 
menu, and preview in a pop-up when you hover 
the mouse pointer on the menu option.

Files in ZIP files are not supported. Image Producers 
(optional)

1.02
2021/12/20

Menu image plus Preview in a pop-up when you hover the mouse 
pointer on a folder menu item. Image and media 
files are supported.

You can specify a "Size" as the maximum width or height of a 
preview.

Image Producers 
(optional)
Hot button, Link bar 
or Horizontal 
Favorites bar

1.04
2022/1/20

1 Retouch Image resize and rotation tool
• Command button
• Menu option "Edit > Retouch"

You can save an edited image as a BMP, GIF, JPG or PNG file. If 
the original is not one of these types, you must specify a file name 
extension for conversion.

{BMKGT} Image Producers 
(optional)

1.15
2021/4/5

1 QuickLook Display a selected / focused file in QuickLook 
window. You can toggle the window by pressing 
space bar or by choosing "Edit > QuickLook".

• Opt for "Extract" to view a file in a ZIP file.
• Opt out "Mouse" to ignore focus movement.

{BMKGT} [QuickLook] 1.11
2022/3/13

mpv Command button to autoplay a selected / focused 
image or media file in a mpv window

• You can customize the file types to support by specifying file 
name patterns (see Appendix A).

• Opt out "Mouse" to ignore focus movement.
• You can detach mpv window from TE by Ctrl+Click the button or

by add-on command "mpv detach".
• Latest version of mpv requires Windows 10 or later. You can use

version 0.36 on Windows 7.

{BMKGT} [mpv] 1.01
2024/1/1

Total Commander 
Lister Plug-in

View a selected file in a new tab with
• Ctrl+Q
• Context command "Content"

Supported file type Plug-in
Image Imagine
Video, audio mmedia
HTML, XML HTMLView
others others

• Plug-in installation
1. Download a plug-in from the internet
2. Unpack the ZIP/RAR file
3. Add the plug-in to TE using the Options page.

▪ Some informational check boxes will be ticked.
▪ In TE64, choose a WLX or UWLX file and let TE detect the 

WLX64 file.
4. Repeat step 1 to 3 for each required plug-in

• Total Commander   the application is not required.

wlx.xml
{BMKG}

[Total Commander 
Lister Plug-in]

1.14
2021/4/5

4.2 Image Producers

Produced images can be used as previews (with File Viewer add-ons), icons (with Thumbnail plus or Show thumbnails with small icons add-on) and wallpapers (with Background image add-on).

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Thumbnail engine 1. Generate a thumbnail of a media file
• MP3 cover
• Still of MP4, WMV, AVI, etc.

2. Generate a thumbnail of a folder according to 
its content, like Windows Explorer.

• "Filter"/"Disable": Enable/disable generation (see Appendix A)
• "Size": Maximum width or height of a generated thumbnail
• "Folder" and "IShellItemImageFactory":

▪ Opt for any one: Enable both media and folder thumbnail
▪ Opt out both: Enable media thumbnail only

• "IThumbnailProvider" and "IExtractImage": Should be ticked

1.09
2022/2/7

https://www.ghisler.com/plugins.htm#lister
https://www.ghisler.com/plugins.htm#lister
https://www.ghisler.com/index.htm
http://www.nyam.pe.kr/dev/imagine/
https://mpv.io/
https://pooi.moe/QuickLook/


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Folder image Present the first image file as the cover page of a 
folder

• Image file search (see Appendix A for the pattern format):
▪ "Filter": The file name must match this pattern.
▪ "Disable": The file name must not match this pattern.

• If you opt for "Expanded", this add-on looks for an image file in 
sub-folders in case none is found in the said folder.

• You can customize the maximum number of files to examine. 
The default is 1000.

• This add-on can store the search results in a database for later 
reuse to speed up. To enable this feature, opt for "Enable" on 
"Cache" page and fill in the path of "sqlite3.dll".

folderimage.db
{T}

[SQLite] (optional) 1.09
2020/12/12

Archive image Extract an image file stored in a ZIP file This add-on is particularly for Retouch and Background image 
add-ons. Other add-ons already have this function built-in.

1.04
2021/1/1

GFL SDK Support additional image types such as PSD, 
EMF and WMF.

Steps to configure:
1. Download GFL SDK from the internet
2. Unpack the ZIP file
3. On the Options page, fill in the paths of "libgfl340.dll" in "libW" 

and "lib64W" folders. All informational check boxes will be 
ticked.

[GFL SDK] 1.08
2021/1/4

Susie Plug-in Support additional image/media types • Plug-in installation
1. Download a Susie plug-in for an image/media type from the 

internet
2. Unpack the ZIP/LZH file
3. Add the plug-in to TE using the Options page.

▪ Make sure "Enable" and "Filter" are ticked.
▪ Tick "Content" if it is an archive extractor.

4. Repeat step 1 to 3 for each required image/media type
• Susie   the application is not required.

spi64.xml
spi32.xml

[Susie plug-in]
• Vector  
• TORO  
• Kana  

1.26
2022/4/17

4.3 Archives and Compounds

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Susie Plug-in plus Open an archive file or a compound file as if it 
were a folder, with the help of a Susie archive 
extractor plug-in. The file will be read-only.

Options (see Appendix A for the pattern format)
• "Filter": The file path must match this pattern.
• "Disable": The file path must not match this pattern.
• "Priority": The file path must match this pattern, if specified. This

option takes precedence over "Filter" and "Disable".

Susie Plug-in 1.03
2024/10/8

Total Commander 
Packer Plug-in

Use an archive file or a compound file as if it were 
a folder. For example:
• Open a 7Z file in a tab and use it like a folder
• Open an ISO file in a tab and open a file in it
• Open an animated GIF file in a tab and copy a 

frame from it
• Open an AVI file in a tab and extract its audio 

part as a WAV file

This add-on is not fully functional with some 
plug-ins. Use it with caution.

• Plug-in installation
1. Download a plug-in from the internet
2. Unpack the ZIP/RAR file
3. Add the plug-in to TE using the Options page.

▪ Some informational check boxes will be ticked.
▪ In TE64, choose a WCX or UWCX file and let TE detect the

WCX64 file.
4. Repeat step 1 to 3 for each required plug-in

• File generator plug-ins, such as CatalogMaker and Diskdir, do 
not work in TE and may cause TE to malfunction.

• Total Commander   the application is not required.

wcx.xml [Total Commander 
Packer Plug-in]

1.16
2024/10/8

https://www.ghisler.com/plugins.htm
https://www.ghisler.com/plugins.htm
https://www.ghisler.com/index.htm
http://www2f.biglobe.ne.jp/~kana/link.html
http://toro.d.dooo.jp/slplugin.html
https://www.vector.co.jp/vpack/filearea/win/art/graphics/loader/susie/
https://www.digitalpad.co.jp/~takechin/
https://newsgroup.xnview.com/viewforum.php?f=4
https://www.sqlite.org/


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Common 
Archivers Library

Use an archive file as if it were a folder

Supported
File Type Package Archiver Type
7Z, ZIP 7z922002.zip SevenZip (7-zip)
LZH ulh3300.exe Unlha (lzh)
RAR unrar32017.exe Unrar 32 (rar)
TAR tar32242.zip Tar

This add-on has many severe problems. It is 
not recommended for use.

• Only DLL files in the packages are required. You can put them 
into one folder to ease administration.

• The packages are 32-bit. To use them under TE64, extract 
UNBYPASS.EXE and UNBYPASS.DLL from UNBYPASS17.ZIP 
into the DLL folder before package installation.

• Package installation
1. Download a package from the internet
2. Extract all DLL files from the ZIP/EXE file with an archiver 

application such as 7-Zip. DO NOT RUN THE EXE FILE.
3. Add the DLL file to TE using the Options page

▪ Choose the archiver type and click "Add"
▪ Click "Browse…" and choose the DLL file. Some 

informational check boxes will be ticked.
▪ Click "Replace"

4. Repeat step 1 to 3 for each required package
• To use RAR under TE32, specify the DLL folder in Dll directory 

add-on.

cal.xml [Common Archivers 
Library]

1.14
2024/10/8

7-Zip Use a 7-Zip archive file as if it were a folder This add-on has many severe problems. It is not 
recommended for use.

[7-Zip] 1.11
2024/10/8

4.4 Designate Applications

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Notepad 
alternative

Run your text editor instead of Windows Notepad 
when TE runs the latter

[your text editor] 1.03
2022/1/15

Replace 
command

You can specify a default application for a file type
using "Tools > Options > Menus > Default" without
changing the settings in Windows Control Panel > 
Default Programs or in Windows Registry.

If you want to do the same for context commands 
(e.g. Open, Edit, Print), use this add-on.

• Steps to configure a file type:
1. Select a file in a file list
2. Open the Options page
3. Click "Get"
4. Click "Regular Expression"
5. Click "Browse…" (at the left of "Add") and choose the 

alternative application
6. Amend the parameters for the application if necessary
7. Click "Add"

• Some file types may support several operations besides open. 
Click "Browse…" on "Verb" line to choose, instead of clicking 
"Get", at step 3.

• To configure another file type:
▪ select another file in a file list, or
▪ click "Browse…" on "Path" line
then repeat from step 3

• Change "$1" in the default line "/^(notepad\.exe)/$1/i" to the 
path of your text editor so that TE uses the latter as its default.

1.09
2022/1/22

Send to Send selected items to a destination. The 
destination type decides the action:
• Application: Run with selected items
• Folder: Copy (if different drives) or move 

(otherwise) selected items to the folder

Drag-and-Drop add-on will override the type of file operation for a 
folder destination.

{T} 1.01
2020/12/23

https://www.7-zip.org/
http://www.madobe.net/archiver/index-e.html
http://www.madobe.net/archiver/index-e.html
http://toro.d.dooo.jp/unbypass17.zip
http://www.madobe.net/archiver/lib/tar32242.zip


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Execution filter Let you associate file path patterns with 
commands. Then when you invoke this add-on, 
TE will execute a command relevant to the 
selection in current file list (specifically the first 
selected item).

Example – add a hot key for this function:
• Key: F12
• Type: Execution filter
• Options:

1. Click Browse…
2. Input a file path pattern (see Appendix A)
3. Click Browse…
4. Choose a command type / a command
5. Click Browse…
6. Choose a command / an option for the command
7. Repeat step 1 to 6 for each required file path pattern

{T} 1.01
2021/1/6

4.5 Ranks and Labels

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Badge Let you manage files/folders by ranks you tag. 
The ranks are displayed as icon overlays.

Steps to use:
1. Select one or more items in a file list
2. Right-click the selection to show Badge menu
3. Choose:

• 0 to 5: Assign this rank to the items
• Open: Search for items with a rank
• Arrange: Sort the file list by rank

• You can filter a file list by specifying "badge:OpRank" in Filter 
bar where Op can be > >= < <=, default is =

• To search for items of any rank and with folder paths matching a
pattern (See Appendix A), enter "badge:pattern" to address bar.

• Badge search result list:
▪ Copy-and-paste or drag-and-drop items TO the list (of a single

rank) to assign a rank to the items.
▪ Cut/copy-and-paste or drag-and-drop items FROM the list to a

real folder will become a file move/copy operation.
▪ Context command "Remove" and pressing Delete key will just

remove the rank. The item itself will not be affected.
• You can set up initial sort by rank using Folder settings add-on.

badge.tsv 1.24
2022/1/26

Label Let you manage files/folders by labels you tag. 
The labels can be shown in a column in a file list. 
Each file/folder can have multiple labels separated
by ;

Steps to use:
1. Select one or more items in a file list
2. Right-click the selection to show Label menu
3. Choose:

• Edit / Add / Remove:  Attach/detach labels
• Details: Show the label column
• Arrange: Sort the file list by label
• Replace folder path / Replace path (label 

search result list): Correct the paths of out-of-
sync label records

• You can filter a file list by specifying "label:pattern" in Filter bar.
• To search for items with a label, enter "label:pattern" to address 

bar. To match multiple labels, separate each pattern with space.
• See Appendix A for the pattern format
• After you rename, move or delete a folder, any label record of 

the folder alone will be updated. Opt for "Synchronize label 
records" to update all label records of the folder branch.

• Label search result list:
▪ Copy-and-paste or drag-and-drop items TO the list (of a single

label) to assign a label to the items.
▪ Cut/copy-and-paste or drag-and-drop items FROM the list to a

real folder will become a file move/copy operation.
▪ Context command "Remove" and pressing Delete key will just

remove the label. The item itself will not be affected.
• You can set up initial sort by label using Folder settings add-on.

label.tsv
{MKGT}

1.45#
2022/1/26

Label button Command button to manage items with a menu
• Edit / Add / Remove: Attach/detach labels
• Details: Show the label column
• label: Search for items with this label
• Filter: Search for items with multiple labels

When you choose a search:
• Keep Ctrl key pressed: Show the search result in a new tab
• Keep Shift key pressed: Refine the current search result with the

choice added for:
▪ multiple labels matching (default)
▪ text pattern matching (if the current address contains ;)

Label 1.15
2021/10/12



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Label groups Organize labels in user-defined groups • Labels will be divided into groups in the menus.
• A label can be assigned to more than one group.

labelgroups.tsv Label 1.03
2021/3/11

Overlay label Display labels on icons (for icon views) or at the 
right of item names (for other views) in file lists, 
with text and/or background colors you have 
chosen for each label.

• You can choose the modes of folder view in which display is 
enabled.

• You can specify a pattern (See Appendix A) for finding out the 
colors. Matching with the pattern list is from top downwards.

• The right side of a label may be partially cropped if you use an 
italic font. Specify a right padding of a space to solve.

overlaylabel.tsv Label 1.01#
2020/11/22

Label SQLite 
ODBC Driver

Store labels in a database • The first time you enable this add-on, TE automatically creates a
database and imports any existing label into it.

• You can use the Load/Save button on the Options page to 
import/export labels from/to a TSV file.

label.db Label and [SQLite 
ODBC Driver]

1.08
2022/3/10

Label SQLite3 Store labels in a database (portable) • The first time you enable this add-on, TE automatically creates a
database and imports any existing label into it.

• You can use the Load/Save button on the Options page to 
import/export labels from/to a TSV file.

• To configure, fill in the path of "sqlite3.dll" on the Options page.

label3.db Label and [SQLite] 1.08
2021/5/4

5 Visual Aids

5.1 Highlight

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Color labels Context command to highlight selected items with 
background colors on file lists and folder trees

• Opt for "Tabs" to color the tab too if you open the item in a tab
• To reset the color, click "Cancel" in Windows Color Palette.

colorlabels.tsv
{MKGT}

1.09
2022/1/4

1 Color label sort Command button to sort a file list by color labels You can use it as an initial sort with Folder settings add-on. {BMKGT} Color labels 1.00
2023/2/1

Colored with filter Display the item name in specific color when it 
matches a specific pattern

• Matching with the pattern list is from bottom upwards.
• Opt for "Path" to use full path name in matching
• See Appendix A for the pattern format

filtercolor.tsv 1.02
2021/3/13

Colored with 
extension

Display the item name in specific color for a 
specific file type

extensioncolor.tsv 1.06
2021/3/13

Colored with 
attributes

Display the item name in specific color if an item 
has a specific attribute (e.g. read-only, hidden)

• NTFS drives may be colored incorrectly as "hidden" or "system".
Specify a color for "Root" to solve this problem.

• NTFS-compressed items are in blue color even without this add-
on. However this feature may disappear when certain add-on 
that changes item color or icon is enabled. Use this add-on to 
solve the problem.

1.07
2022/2/24

Colored with 
modify date

Display the item name in specific color if an item is
modified in a specific elapsed time

• Elapsed time can be specified in seconds, minutes, hours, days,
weeks or years, but the actual calculation will be in seconds.

• Example: "1d" will match any item modified in the past 86400 
seconds.

• 1 year is assumed 365 days. No leap year handling.

modifydatecolor.tsv 1.09
2021/5/21

Colored with 
access date

Display the item name in specific color if an item is
accessed in a specific elapsed time

accessdatecolor.tsv 1.05
2021/3/13

Colored with 
create date

Display the item name in specific color if an item is
created in a specific elapsed time

createdatecolor.tsv 1.05
2021/3/13

https://github.com/tablacus/TablacusExplorer/issues/674
https://www.sqlite.org/
http://www.ch-werner.de/sqliteodbc/
http://www.ch-werner.de/sqliteodbc/


5.2 Icon Replacement

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Extension icon 
changer

Display another icon for a specific file type This add-on works in file list only. extensionicon.tsv 1.17
2021/3/15

Path icon changer Display another icon for a specific file/folder path • Put this add-on at the top of your add-on list, so that it overrides 
any icons set by other add-ons.

• You can edit the setting for current folder/selection by a menu 
option, a hot key or a mouse gesture if you configure this add-
on as such.

pathicon.tsv
{MKG}

1.21
2022/2/24

Filter icon changer Display another icon when the file/folder path 
matches a specific pattern

• This add-on works in file list only.
• Matching with the pattern list is from top downwards.
• See Appendix A for file/folder path pattern format

filtericon.tsv 1.11
2021/3/15

Icon changer 1. Display another icon for:
• opened folders (folder tree only)
• closed folders
• all undefined file types
• a specific file type

2. Display another icon overlay for:
• shortcuts
• network shares (on XP style windows)

• This add-on works for icon size up to 48.
• "SysSmall" icon is for folder tree while "Small", "Large" and 

"ExtraLarge" icons are for other places.
• "Undefined" means that the file type is not associated with any 

application in Windows.
• For a specific file type:

▪ It must have been associated with an application in Windows. 
Otherwise nothing will happen.

▪ Specify it with a dot, e.g. .PDF

iconchanger.tsv 1.09
2020/12/14

Folder large icon 
changer

Display a fixed icon for any folder when icon size 
is 32 or larger

• TE embellishes folder icons with folder contents when icon size 
is medium or larger. This add-on lets TE omit this process and 
speed up.

• You must specify an icon on the Options page.

1.04
2020/12/13

Thumbnail plus By default, "Always show icons, never thumbnails"
option in Windows Control Panel > Folder Options
is opted OUT. Thus the icon of a folder and an 
image/media file (with native support by Windows)
becomes a thumbnail when icon size is 17 or 
larger.
1. This add-on lets you control which file types are

eligible for thumbnails, if you opt FOR the 
control panel option.

2. This add-on lets TE support additional file types
for thumbnails with the help of an image 
producer add-on.

• This add-on works only when icon size is 33 or larger.
• Options (see Appendix A for the pattern format)

▪ "Filter": Enable thumbnails for these additional file types.
▪ "Disable": Disable thumbnails for these additional file types.
▪ "Priority": Enable thumbnails for these file types. If specified, 

this option takes precedence over "Filter" and "Disable".
▪ "Folder": Enable/disable folder thumbnails.
▪ "Icon": Display a file icon on a thumbnail.

Image Producers 
(optional)

1.22
2024/2/28

Show thumbnails 
with small icons

• This add-on works only when icon size is 32 or smaller.
• Options (see Appendix A for the pattern format)

▪ "Filter": Enable thumbnails for these file types.
▪ "Disable": Disable thumbnails for these file types.
▪ "Folder": Enable/disable folder thumbnails.

Image Producers 
(optional)

1.01
2020/12/17

ADS Thumbnail Display a thumbnail as the icon of an item, when 
icon size is 33 or larger. The thumbnail is retrieved
from NTFS alternate data stream.

• Use X-Finder add-on to create / delete such thumbnails
▪ Thumbnail: create %selected%
▪ Thumbnail: delete %selected%

• Caution: Such thumbnails occupy disk space but are hidden. 
You can find them with DIR /R command.

1.04
2020/12/14

Overlay icon of 
nonexistent items

Overlay a red cross on the icon of any non-
existent item

This add-on helps you to identify any renamed, moved or deleted 
item in a file list provided by History, Speed dial, Entered history, 
Badge, Label and Clip folder add-ons.

1.02
2020/12/20



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Icon overlay Windows limits the number of icon overlays that 
applications, such as OneDrive and TortoiseSVN, 
can show. Therefore you may have a display 
problem if you have installed many such 
applications. This add-on lets TE break this limit.

• Set "Base" to 0
• You can opt to apply to icons in file lists and/or folder trees.

1.12
2024/2/9

5.3 Application Appearance

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Folder icon Automatically change TE icon to match with 
current tab

1.04
2021/5/7

Application Icon Let you specify an icon for TE 1.03
2021/8/18

˄ Segoe Fluent 
Icons

Change the faces of common image buttons and 
text buttons to neat symbols (Segoe Fluent Icons 
or Segoe MDL2 Assets)

Font installation:
1. Download the font pack from the internet
2. Extract the font file from the ZIP file
3. Rename the font file to "SegoeIcons.ttf" / "segmdl2.ttf"
4. Open the font file and press the "Install" button

[Segoe Fluent Icons 
font] (Windows 7 to 
10)

1.04
2022/2/9

Segoe UI MDL2 
Assets

Change the faces of common image buttons to 
neat symbols (Segoe MDL2 Assets)

[Segoe MDL2 Assets
font] (Windows 7)

1.02
2022/2/9

Font settings 1. Customize the font used by TE
2. Customize the height of folder tree items

"Height" affects vertical spacing, not font size. Specify -1 for 
condensed spacing.

1.25
2022/7/24

Color Customize the colors of file lists and folder trees 1.13
2022/1/15

Dark mode Use white text on black background as color 
theme

On Windows 10:
• Choose "Dark" as your default app mode (Settings > 

Personalization > Colors) to color the areas this add-on does 
not handle.

• Opt for "Auto" so that TE will adapt to the current app mode.

1.19
2024/4/21

Window Alpha Show TE window with semi-transparency 1.04
2024/8/2

Window Fadeout Fade out TE window if there is not any mouse 
activity in a specified period

TE window will fade in upon any mouse activity on TE 1.20
2024/7/31

Background 
image

Show a specific image on file list background 
when the folder path matches a specific pattern

• Matching with the pattern list is from bottom upwards.
• See Appendix A for folder path pattern format.

bgimage.tsv Image Producers 
(optional)

1.09
2022/2/23

Underline Display underlines to separate each row of items 
in a file list

1.02
2020/12/14

Size bar chart Display a bar representing the item size on each 
item in a file list

• To show the bars for folders, choose "Total file size" column 
from "View > Choose Details" dialog box.

• Use "Filter" option (see Appendix A) to limit where this function 
is enabled.

1.02
2020/12/24

List width Use a user-specified width to display each item in 
list view (item name may be shortened), instead of
Windows default of varying width (full item name 
is displayed)

If your folder stores many items with very long names, this add-on 
will speed up scrolling because more items can be displayed on 
each page.

1.05
2021/4/7

https://aka.ms/segoemdl2
https://aka.ms/segoemdl2
https://aka.ms/SegoeFluentIcons
https://aka.ms/SegoeFluentIcons


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˅ Fast list mode Use the same width as small icon view to display 
each item in list view (item name may be 
shortened), instead of Windows default of varying 
width (full item name is displayed)

If your folder stores many items with very long names, this add-on 
will speed up scrolling because more items can be displayed on 
each page.

1.04
2022/2/19

Icon label plus If an item name is in one line and cannot be 
displayed in full, split it into two lines.

Medium or larger icon views only 1.03
2024/10/5

Gridlines Display grid lines in details view Not available when grouping is used 1.05
2021/4/7

Stripes Use alternating background color to distinguish 
each row in details view

Not available when grouping is used 1.13
2022/7/21

˅ Stripes lite Use alternating background color to distinguish 
each row in details view

1.09
2022/2/5

Tab design Customize the appearance of tabs
• 5 predefined styles are available
• You can specify your own style in CSS syntax

• You can save your style as a CSS file and load it later.
• Your style will be applied to any tab on any option page, Tab 

plus and Tab groups.

1.16
2022/2/23

User style sheet Customize the appearance of TE using CSS • You can find default styles in:
▪ "index.css" and "options.css" in "script" folder of TE
▪ "style.css" in "addons\darkmode" folder of TE for dark mode

• Click "Open" button to edit the config file with default text editor. 
Click "Refresh" button to reload the file to Options page.

user.css 1.08
2021/12/16

VBS InputBox Replace web browser input box with VBS input 
box

This add-on is disused. 1.02
2020/12/23

6 Tailoring

6.1 Title Bar

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

˄ Title bar Show the name or path of current tab on title bar 1.09#
2021/8/17

Hide Title bar Do not display TE title bar You can toggle the title bar by a menu option, a command button, 
a hot key or a mouse gesture if you configure this add-on as such.

{BMKGT} 1.10
2022/2/7

Grab bar Enhanced TE title bar:
• Show the name or path of current tab
• Drag to (restore and) move TE window
• Double-click to maximize / restore TE window

• Right-click to show application context menu
• You can use Grab button, Grab bar, Minimize button, Maximize 

button and Close button together to assemble a title bar.

1.12#
2021/4/15

Grab button • Drag to (restore and) move TE window
• Double-click to maximize / restore TE window

Right-click to show application context menu 1.10
2021/4/16

Minimize button Command button to minimize TE window Right-click to show application context menu 1.08
2021/4/5

Maximize button Command button to maximize / restore TE 
window

Right-click to show application context menu 1.09
2021/4/5

Close button Command button to close TE window Right-click to show application context menu 1.06
2021/4/5



6.2 Drag and Drop

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

To the top in the 
drag

Bring TE window to the front when anything is 
dragged from another application

1.03
2020/12/22

Drag-and-Drop Set the default file operation to either copy or 
move when you use drag-and-drop without 
pressing Ctrl, Shift nor Alt.

1.03
2021/5/15

Confirm drop Let you confirm the operation when you drag-and-
drop something to a tab

1.02
2021/3/17

Right button drag-
and-drop menu

Customize the menu of right button drag-and-drop

You can add menu items to
• create symbolic links
• run an application with dropped items

• Name: Menu item name
• Class: "Exec" to run an application
• Path: Path of the application to process dropped items
• Options:

▪ %Dropped%: Paths of all dropped items (run the app once)
▪ %Each%: Path of each dropped item (run the app for each)
▪ %Dest%: Destination folder path
▪ %Name%: File name of %Each%
▪ %Unique%: Generated destination path for %Each%
▪ %IsFolder:/d%: Resolve to "/d" if %Each% is a folder

• RunAs: Run the application with administrator privilege
• Hidden: Hide the application window when it is run
• NTFS: Show the menu item only when destination is in NTFS
• Filter: Show the menu item only when destination folder path 

matches this pattern (see Appendix A)

dragdropmenu64.xml
dragdropmenu32.xml

1.04
2023/2/8

6.3 Startup and Settings

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Add-on switcher Switch add-ons on or off.
• Options format (one line each):

▪ Toggle: AddonID
▪ Switch off: AddonID,0
▪ Switch on: AddonID,1

• Example – add a tool bar button to toggle Side tree view:
▪ Name: Folder Tree is %AddonStatus:sidetreeview%
▪ Type: Addon switcher
▪ Options: sidetreeview
▪ Icon: (choose one you like)

{T} 1.03
2021/1/19

Run at setup Do something when TE loads or reloads your 
settings

1.04
2022/1/23

Startup settings Do something when TE starts • Example – load a layout when TE starts:
▪ Type: Load layout
▪ Options: (click Browse… to choose your layout file)

• To skip a startup action one time, keep Shift key pressed when 
TE starts. Opt for "Shift" to enable this feature.

1.11
2022/1/23

1 Restart Restart TE on your request Menu option: "File > Restart" {BMKGT} 1.09
2021/12/10

Auto restart Restart TE after a period of inactivity You can specify the period in "Hours:Minutes" format. 1.02
2020/12/18



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Auto save By default, TE saves your settings when needed 
and when it exits. This add-on lets TE also save 
the settings periodically.

You can specify the period in minutes. The default is 5. 1.03
2020/12/19

Save custom 
colors

Save your custom colors added to Windows Color
Palette as a part of TE settings

custcolors.txt 1.02
2020/12/22

Auto backup 1. Make a daily backup of TE config folder when 
TE saves your settings

2. Let you restore your settings from a backup

• You can customize the location of backup folder. The default is 
the parent folder of TE config folder.

• You can customize the number of backups to keep. The default 
is limitless.

1.03
2020/12/13

Run on exit Do something when TE closes 1.02
2022/1/22

Multiple 
executions

Let you run multiple instances of TE which share 
the same set of settings

• "Drag a tab and drop it outside" feature of Tab plus will become 
"Open the folder in a new / another instance of TE".

• You can use "Open in new window" command to open your 
folder in a new instance of TE.

• You can use command line option /nw to run TE in a new 
window.

{T} 1.09#
2021/4/11

6.4 Access from Windows

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Launch the app 
on system startup

Start TE when Windows starts up A shortcut to TE will be created in your "Startup" folder in Start 
Menu.

1.01
2021/7/3

Jump list Manage your TE jump list in Start Menu and Task 
Bar

jumplist.tsv
{MKGT}

1.05
2022/2/24

Systray Opt to show TE icon in Notification Area
1. when TE is minimized
2. when TE is closed by clicking ╳ button on the 

title bar

• You can also opt to show the icon whenever TE is running.
• When this add-on is enabled, you need to choose "File > Close 

application" to exit TE completely.

1.15
2021/8/20

Hot key Set a Windows hot key to bring up TE window TE must be running when you press the hot key. 1.01
2020/12/21

6.5 Replace Windows Explorer

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Open instead Automatically open the folder in a new tab when it 
is opened in Windows Explorer. The Explorer 
window is then closed.

• To configure this add-on for use:
▪ Tick "Real Folders"
▪ Tick "Special Folders" (if necessary)
▪ Tick "Take over the Explorer view" (if necessary)

• "Take over the Explorer view":
▪ Take in view mode, sorting and grouping from Explorer
▪ Columns will NOT be taken in
▪ May NOT work if you have enabled Remember folder view 

settings, Take over folder view settings or Folder settings add-
on.

1.14
2024/2/8

1 Import Explorer Command button to open all folders in new tabs 
that are currently opened in Windows Explorer. 
The Explorer windows are then closed.

{BMKGT} 1.12
2024/2/12



Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Shell execute 
hook

1. Run TE instead of Windows Explorer when:
• you press Win+E
• you run Windows Explorer from:

▪ Start Menu
▪ Task Bar (when pinned)
▪ Run dialog box (Win+R)
▪ Command Prompt

• an application runs Windows Explorer

2. Run TE to open the folder in a new tab instead 
of Windows Explorer when:
• you input a folder path in the Run dialog box
• you input "start folder path" in Command 

Prompt
• an application opens a folder in Windows 

Explorer

This add-on does not work on Windows 10 
version 21H1 and newer.

• TE needs not be running when it is invoked this way.
• You can still run Windows Explorer by other ways such as:

▪ choose "Computer" from Start Menu
▪ click Recycle Bin on Desktop
▪ click a folder shortcut on Desktop or Task Bar
▪ choose "Open in Explorer" from tab context menu

• Running TE from another application may or may not work, 
depending on the technique used by that application.

• You can use "Open instead" add-on to handle cases this add-on
misses.

• Steps to configure (administrator privilege is needed):
1. This add-on will install a program to Windows. You are 

advised to manually create a system restore point first.
2. On the Options page:

▪ tick all "Registry" options
▪ click "Default" and reply "OK"
▪ tick "Windows Explorer"
▪ click "OK"

3. Your desktop will refresh to complete the configuration.
▪ If you do not tick "Windows Explorer", you will need to 

restart your computer to complete the configuration.

1.13
2021/11/5

7 Keep Running

7.1 Program Update

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Auto update Automatically check for and update to a new 
version of TE

• You can customize the check frequency in days. The default is 
everyday.

• This add-on does the check after 10 minutes of inactivity. You 
can customize this period in minutes or in hours.

• TE will prompt you before update. Opt for "Auto" if you do not 
need the prompt.

• If you want to update add-ons together, enable "Add-ons 
updater" add-on.

autoupdate.txt 1.03
2020/12/23

Add-ons updater Update all installed add-ons together with TE
• when you choose "Help > Check for updates"
• if you use "Auto update" add-on

To update add-ons but not TE, use "Addons updater" command. {T} 1.10
2021/12/17

Download Use another application to download
• add-on list
• icon pack list
• language file
• TE program ZIP file
• add-on program ZIP files
• icon pack ZIP file
when you use a program update function

• Usually this add-on is not needed. TE uses a Windows built-in 
function to do the download.

• Click a button on the Options page to choose an application. 
Then amend the path of cURL / Wget. No need to amend the 
path of PowerShell and BITSAdmin which are Windows built-in.

• If you choose PowerShell, note that version 3.0 or above is 
required. The built-in version on Windows 7 is just 2.0.

• To show trouble-shooting messages during download, opt for 
"Visible".

[cURL] or [Wget] 
(optional)

1.08
2022/3/9

https://www.gnu.org/software/wget/
https://curl.haxx.se/


Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Extract Use a third-party application to extract program 
files of TE and add-ons as well as icons from 
downloaded ZIP files when you use a program 
update function

Usually this add-on is not needed. TE uses a Windows built-in 
function to do the extraction.

[7-Zip] 
(recommended)

1.15
2022/3/11

WebView2 (Edge 
Blink engine)

Help you to download and install software to 
switch TE to Edge Blink engine

• TE will restart with an appropriate engine (Edge Blink or IE) after
you confirm "Check for updates" or "Delete".

• This add-on is not required to use the Edge Blink engine, but 
will be useful when any update is available.

1.01
2024/10/14

7.2 Fix

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Open Control 
Panel in Explorer

Open Windows Control Panel in Windows 
Explorer when you click it in TE

• This is a fix to a loophole that TE may allow you to navigate to a 
control panel item but the tab may not work.

• With the patch, this add-on is is no longer required.

1.02
2018/1/30

Fix selection on 
sort and update 
dir

Keep your selection after you
• sort a file list, or
• create an item by pressing F7, Ctrl+K or Ctrl+S

• This is a fix to the case that if you:
▪ select some items, then
▪ deselect any of them, then
▪ sort the file list
the deselected items will incorrectly become selected.

1.16
2021/4/8

Fix Windows 11 
bug

Solve a tip pop-up display problem of TE on 
Windows 11

Tip pop-up does not disappear after the mouse pointer is moved 
away from a selected item in a file list. This add-on solves the 
problem.

1.06
2022/2/9

Fix Windows 10 
Fall Creators 
Update bug

Solve a mouse problem of TE on Windows 10 The mouse pointer may unexpectedly jump to a corner of the 
screen when you drag an item in a file list. This add-on solves the 
problem.

1.01
2017/11/4

Fix Windows 10 
Creators Update 
(RS2) bug

Solve a file list display problem of TE on Windows 
10 version 1703 (version 10.0.15063)

• Current file list may disappear after pressing F5. This add-on 
solves the problem.

• This add-on is not needed on newer versions of Windows 10.

1.04
2018/2/25

No emphasis Do not change the background color of a sort 
column in details view

This add-on was a fix to a background color problem. It is no 
longer required since TE 20.6.17.

1.01
2020/6/17

Dll directory Designate a folder to find third-party DLLs which 
are not in add-on folders

Try this add-on if you get a problem about loading a DLL file. 1.02
2020/12/18

https://github.com/tablacus/TablacusExplorer/issues/692
https://www.7-zip.org/


8 Miscellaneous

8.1 Network and System

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

Total Commander 
File System Plug-
in

Access various services provided by plug-ins. For 
example:
• Read disk partitions and images: "DiskInternals 

Reader" plug-in
• Access files on a WebDAV server: "WebDAV" 

plug-in
• Access cloud storage: "Cloud" plug-in

This add-on is not fully functional with some 
plug-ins. Use it with caution.

• Plug-in installation
1. Download a plug-in from the internet
2. Unpack the ZIP/RAR file
3. Add the plug-in to TE using the Options page.

▪ Some informational check boxes will be ticked.
▪ In TE64, choose a WFX or UWFX file and let TE detect the 

WFX64 file.
4. Repeat step 1 to 3 for each required service

• Steps to use:
1. In an address bar, enter \\\ or choose \\\ from a menu
2. Choose a service from the list

• When you sort a file list, files and folders will be sorted together. 
Opt for "Arrange by: Folder Top" to sort them separately like 
Windows Explorer.

• Total Commander   the application is not required.

wfx.xml [Total Commander 
File System Plug-in]

1.27
2021/11/24

1 Control Panel 
button

Command button to show a menu of control panel
items in category sub-menus

1.10
2021/12/15

1 Run Command button to show the Run dialog box of 
Windows

If you enter a folder path, the folder will be opened in a new tab. 
Press Ctrl+Enter to open it in Windows Explorer.

{BMKG} 1.07
2021/4/2

Command in 
address bar

Let you enter commands through an address bar 
similar to using the Run dialog box of Windows

• The function has become built-in since TE 22.3.2.
• If you enter a folder path and press Shift+Enter, the folder will be

opened in Windows Explorer.

Address bar (or its
"Inner" version) or 
Simple Address bar

1.01
2021/5/10

8.2 Asian

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

C/Migemo Convert a phonetic input to a regular expression 
behind the scenes for Japanese filter and search

Steps to configure:
1. Download C/Migemo from the internet
2. Unpack the ZIP file
3. On the Options page:

• Fill in the path of "migemo.dll"
• Fill in the path of "migemo-dict" (in dict\utf-8 folder)
• Click "UTF-8(CP65001)"

4. Opt for "Regular Expression/Migemo" in Inner Filter bar, Filter 
bar and Filter button add-ons if you want to omit the 
surrounding /

5. Opt for "Regular Expression/Migemo" in Everything add-on

[C/Migemo] 1.06
2020/12/5

Auto Disable IME Change keyboard input mode to English when 
you "type to jump" in a file list or in a folder tree

1.03
2020/12/5

https://www.kaoriya.net/software/cmigemo/
https://www.ghisler.com/plugins.htm#filesys
https://www.ghisler.com/plugins.htm#filesys
https://www.ghisler.com/index.htm


8.3 Developers

Add-on Name Function Note Config File
{Access}

Another add-on or 
[application] required

Version
Date

1 System folders Command button to show a menu of folders which
application developers may be interested in

If you configure this add-on as a menu option, the folders will be 
listed in a sub-menu. Opt for "Flat" to list them in a specific menu.

{BMKGT} 1.12
2021/12/15

Copy Data URI 
Scheme

Context command to generate Data URI from a 
selected file into Windows Clipboard

{MKGT} 1.05
2021/12/26

External script Run a script file {T} 1.01
2020/12/10

Async script Run a script file as a separated process To run the sample script, add TE folder path to the first line. {T} 1.01
2020/12/9

X-Finder 1. Let you use X-Finder commands in TE
2. Provide additional environment variables

See Wiki for details

Useful commands:
• ClipPath:1A / ClipPath:18

Copy names / paths of selected items to Windows Clipboard, 
one line each, without quotes.

• Input:,"Message1","Message2",DefaultValue
Enter the value of %InputData%. Click Cancel button to abort.

• Numbering:"Pattern",StartValue,Increment
Rename selected items to serial numbers (keep extension)
%d = serial number, %.nd = n-digit with leading zeros
Example:
Input:,"Start value",,1
Numbering:"Photo%.3d",%InputData%,1

• Numbering:"Pattern",,,"FindText","ReplaceWith"
Rename selected items with replaced text (case sensitive)
First %s = base file name, %.ns = first n characters
Second %s = .extension, %.ns = first n characters (including .)
Example: Numbering:"%s%s",,,"IMG",""

{T} Image Producers 
(optional)

1.31
2021/1/28

Debug Debug message pane
• JScript command:

▪ Addons.Debug.alert("message") Display a message
▪ Addons.Debug.alert(["part1", "part2", …]) Display a comma-separated message
▪ Addons.Debug.set("message") Clear the pane and display a message
▪ Addons.Debug.set(["msg1", "msg2", …]) Clear the pane and display messages
▪ Addons.Debug.clear() Clear the pane

• Opt for "Change notify" to automatically show any file operation taken

1.03
2021/4/15

Firebug Lite Debug TE using Firebug Lite Enable this add-on to show the debug pane. Your computer must 
have connected to the Internet.

1.01
2020/11/27

˄ Default add-on
1 To add it to every pane, place it in an "Internal" bar.
2 To add it to every pane, use "Inner" version (under Panes).
˅ Windows Vista or later is required

Version # = patched version

{Access} You can configure this add-on to access it in alternative ways:
• B Command button
• b Tool bar
• M Menu option
• K Hot key
• G Mouse gesture
• T Add-on command, which you can give through a tool bar button, a hot key, a mouse gesture, a menu option or command line:

▫ Chosen from "Type" drop-down box = command line TE64.exe "Add-on command,Options"
▫ Chosen from "Browse" menu while "Type" is "Add-ons" = command line TE64.exe "Add-ons,Add-on command"

https://github.com/tablacus/TablacusExplorer/issues/692
https://github.com/tablacus/TablacusExplorerAddons/wiki/xfinder
https://gist.github.com/tablacus/d8b6a64ed135fe9437f95e0fa952db28


APPENDIX

A. File/Folder Name Pattern
You can specify a name pattern either in a wildcard format or in a regular expression.

Wildcard Format
• A text pattern accepting * and ? as wildcards
• * stands for any number of any characters
• ? stands for any one character
• Use ; to separate multiple text patterns of which any one to match with
• Case insensitive
• Examples:

▪ AB? match item name with 3 characters and starting with ab
▪ *ED match item name ended with ed
▪ ab?;*ed match any one of the above

• For Filter bar, Filter button and Find files: If no wildcard is found in a text pattern, TE will treat the latter as if it were surrounded by *

Regular Expression
• Surrounded by /
• Case sensitive, unless "i" is appended
• See JavaScript RegExp Reference for a complete reference
• Examples:

▪ /^C/ match item name starting with C
▪ /^C/i match item name starting with C or c
▪ /tab/ match item name containing "tab"

• For Filter bar and Filter button: If you opt for "Regular Expression/Migemo", you can omit the surrounding /
• Regular expression cannot be used for searching with Find files, Information search, Badge and Label add-ons.

B. Quick Access to Options
You can open the options page of an add-on quickly by a hot key, a mouse gesture, a tool bar button or a menu option in 2 ways.
You can find (AddOnID) under each add-on name in "Tools > Add-ons". It is also the folder name under TE addons folder.

Type Options

Standalone add-on options window JScript / JavaScript AddonOptions("AddOnID");

TE options window Options Add-ons&ID=AddOnID

https://www.w3schools.com/jsref/jsref_obj_regexp.asp
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