Tablacus Explorer Add-ons by Category

(I [T T0 L B LYoo TP P PP PPPPPPPRI 2
P O] 10 0E= 1o ol == TS OO PO PSP P TP PPPPPPPPPPN 2
R =1V - Lo o TP PSP UP PP PP 2
L o] o [T Y1 PP PP P TP P PP PPPTPPPRP 3
LT o] ¢ (o Y711 o] (o [T = TP TSP PPPPPPPPPPPPP 4
L 11 = TP P TP PSP P TP PP OPPPPPRRPPON 5
=TS Lo TP PSP O U PP PR OPRPPI 5
TS T= 1= SO PO U PP PP OPPPPPRRPPN 5
LIS =11 o TSP PP PP TSRO PP PR OPRP PRI 6
(L ®1 1o oTo Y= o TP PP PR P TP TUPPRTI 6
(N S O o1 =1 To o - TSP PT ST P PR OPPPPP 7
(0 1= [ o] 4 0= 111 ] o FO PP PO PP P PP P T PPPPPPP 7
B o] (o [=T I =T TP P TP UPPOPPPI 7
L o= 1Yo 41 (1 T ST P U P PP PPPPPPPPRP 8
BT = o T PP PP P PP PP PPPPPPPPPP 9
(LT =T LT ST PP ST P PP PP SR PPPR PP 10
L A o] 6T o =TT TP TP PP PP PP OPPPPPPPP 11
(R B SR (U leo T g1 aaT=Te OO TSSO TRP PP 11
(RS e (A TSNV T o o o =T = T OO OO TP P PP PP PPPPPP 11
A R S = Ll o =T o =T o] PO T TP T P UP PP PPPRPP 12
b2 I o e 01T | o AU PU PRI 12
R (ool g T =T o] F= (o=t 00 [T o | OO TP P PP PP U PP PP PP PPPPPPP 13
AN Y ool Tor= 1 (o g WY o] o 1= T = o [o = T T T PSP PPPP PP PPPRPP 13
P 1o TR 0] o o OO PP PO PP PP R TTPPPPPPP 14
AT =T (0 o J=Ta Lo RS T 11] oo - TP PO SPPT PP PPP PR PPTPPP 15
P == R TN o) Yoo =TT TSSO TSP PP PP PSP PPPPPPN 15
A S T o = Tet A T o fo T o o] o] = ST TP PSSP PP PP PPPPPPPN 16
P < T Lo T ] - TSP PP PPPPPPRRIN 16
A B LY=o oL (PP TSP PTRP PP 17
RGO OO TP PP PP OPOPPPPRPPN 17
LY o] o1T ol > Nl 1 T=Y ) o] o [T\ F= g o o= Vi (=T o TP POV OP PP UPPPURPPPPN 17
Note:

This list is yet to be completed. 154 out of 192 add-ons are documented here. Last updated: 2017/12/24.

© Gaku (author of Tablacus Explorer) and ccfs (author of this document)



Input Devices

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Key Customize hot keys There are some predefined defaults. key.xml 1.16
2017/3/23
A Mouse Customize mouse gestures » There are some predefined defaults. mouse.xml 1.20
» More mouse customization options can be found in "Tools > 2017/8/16
Options > General > Mouse".
Long press Enable “long press” as a mouse gesture, which is | You can customize the elapsed time to press (in milliseconds). 1.00
common in touch screen devices The default is 500 (i.e. half a second). 2017/7/30
2. Command Bars
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Al Main Menu Main menu bar To customize the menu, choose "Tools > Options > Menus". 1.1
2015/12/30
Main Menu Button | Command button to show the main menu To change the menu bar to a button: 1.04
1. Enable this add-on 2016/5/27
2. Disable “Main Menu” add-on
A Tool bar Customizable tool bar toolbar.xml 1.25
2017/6/11
Link bar Customizable tool bar with drag-and-drop support | You can add a button by drag-and-drop an object to an empty linkbar.xml 1.18
space of the link bar. The object can be a tab, a folder, a file or a 2017/6/11
program.
Simple Tool Bar Tool bar of 5 buttons: back, forward, up, new tab | Its functions can be achieved by individual add-ons which are 1.03
and refresh. customizable and have more functions. 2013/3/3
3. Navigation
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Address Bar Breadcrumbs address bar To change to classic style, tick “XP style” in the add-on 1.38
configuration page. 2017/10/14
Al Back Command button to go backwards 1.09
+ Click: Go to last visited folder 2014/3/16
+ Right click: Show a menu of visited folders
A Forward Command button to go forwards 1.09
+ Click: Go to the folder just went back from 2014/3/16
* Right click: Show a menu of folders went back
from
N Up Command button to go upwards 1.1
* Click: Go to parent folder 2017/7/127

* Right click: Show a menu of ascendant folders




* across TE sessions

from a file folder to a system folder (such as “Computer”) and
then back. This add-on solves the problem.

» By default, TE applies the view in Windows Explorer when it
starts. This add-on lets TE apply the last used view in TE.

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
DriveBar Tool bar of drive buttons TE can refresh the drive bar automatically when any drive is 1.08
* Click: Open the root folder in a new tab added or removed. 2016/3/16
* Right click: Context menu of the drive
Drive button Command button to show a menu of drives Right click to show the context menu of “Computer”. You can 1.03
connect to or disconnect from a network drive using the menu. 2017/8/2
Folder button Command button: 1.01
+ Click: Open a folder as per input to a dialog box 2016/3/16
* Right click: Show a menu of sub-folders of the
current folder
Simple Address Text-only address bar 1.07
Bar 2017/12/20
Select tab Switch to the tab with folder path specified in » The folder must already be opened in the active pane. 1.00
“options”  Useful if you need to switch to a specific folder frequently using 2016/11/5
a hot key.
* Example:
1. Choose “Tools > Add-ons”
2. Click “Options” of “Key”
3. Add a hot key with:
= Key: F12
= Type: Select tab
= Options: (type in a folder path or click Browse... to choose)
Undo Close Tab Context command to re-open the tab last closed closedtabs.xml 1.07
2016/8/22
Recently closed Command button and context command to show Undo Close Tab 1.01
tabs a menu of recently closed tabs for re-opening 2016/11/6
History Command button to open a new tab showing a list | You can customize the maximum number of folders to record. The | history.tsv 1.06
of recently opened folders default is 1000. 2016/8/15
Speed Dial Show a list of recently opened folders when you The default new tab is changed as such. speeddial.tsv 1.06
add a tab 2016/3/1
4. Folder View
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Reset Columns Apply the column settings in Windows Explorer * Menu option: “File > Reset Columns” 1.00
details view to the current folder » The applied settings may not be remembered by TE unless one 2015/10/15
of the following “Folder View” add-ons is enabled.
Remember folder | Remember the view of each folder when you remember.xml 1.30
view settings navigate, like the default behavior of Windows. 2017/7/15
Take over folder | Apply the same view to all file folders » By default, TE adheres to the current view when you navigate, |takeoverfoldersettings.txt 1.03
view settings * when you navigate, and but it may change the view unexpectedly when you navigate 2017/7/15




browse, if the latter is not currently in the view.

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Folder settings Apply a specific view to a specific folder based on |« By default, TE adheres to the current view when you navigate. |foldersettings.xml 1.14
folder name pattern This add-on lets TE adhere to the rules you specified, 2017/7/16
regardless of the current view.
» Steps to use:
1. Customize the view to your need
= choose the type of view (icon, list, details, etc.)
= choose the columns and the width of each
= sort the items (not applicable to query results)
2. Choose “View > Customize this folder”
= click “Get the current folder view”
= change “Filter” to a folder name pattern if necessary
= click “Add”
* Filter format:
* see Appendix A
= special folder is represented by a number
= query result is represented as query:
= examples:
= Local and network file folders  ?:\*;\\*
= Computer 17
= Recycle bin 10
= Browsing history history:
= Everything search result es:”
+ First set up the view for general file folders. Then set up the
views for exceptions.
5. Working with Folders
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date

Refresh Command button to refresh the file list of the 1.05
current folder 2015/7/1

Mixed sort Command button to sort files and folders together |+ This sorting order cannot be preserved in a folder view. 1.01
(Windows sorts them separately). You can sort by |+ Require Window Vista or higher 2015/6/16
name or modified date, in ascending or
descending order.

Total file size sort | Command button to sort all items by “Total File » “Total File Size” is: 1.02
Size” in descending order, and display the column = for a folder: total size of all files under the folder branch 2015/7/1
if not yet. = for a file: same as its size

* This sorting order cannot be preserved in a folder view.
* Require Window Vista or higher

Flat Tab context command to show all items under the 1.01
current folder branch as a flat list 2017/3/23

Replace slow TE automatically replaces the slow "Date" column | Usually this add-on is not needed because the slow “Date” column 1.02

columns with the fast "Modified Date" column when you is not a default. 2017/10/9




6. Filter
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Filter bar Show items with names matching an input filter * Filter format: 1.19
and hide those do not = see Appendix A 2017/8/5
= If only normal text is specified (no * ? ;), any item with its
name containing the text anywhere will be matched.
» Can opt to support regular expression and Migemo
Filter list Click the filter icon to show a menu of user- filterlist.tsv Filter bar 1.01
defined filters 2017/8/6
Filter button Command button to input a filter 1.00
2016/2/23
7. Search
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Search bar File/folder search using Windows Search Windows Search can still be invoked by pressing Ctrl+F even 1.04
without this add-on. 2017/12/15
Everything File/folder search using Everything Can opt to support regular expression and Migemo [Everything] 1.22
2017/6/5
Find files Search by file name (accept wildcards) and/or by |+ Default hot key is F3 1.04
text contents (case insensitive) + Folders are excluded from search 2017/4/6
+ See Appendix A for input file name format
Empty folder Search for empty sub-folders under the branch of: 1.06
+ the current folder (when no item is selected), or 2017/2/6
+ the selected folders
then list the result in a new tab
8. Select
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Wildcard Select items with names matching an input » Menu option: “Edit > Wildcard Select...” 1.00
Selection pattern » See Appendix A for input pattern format 2013/9/9
Check box Use a check box beside each item for selection + To use this add-on, you must opt “double click to open (single 1.03
click to select)” in “Folder Options” of Windows control panel. If 2015/5/30
you opt “single click to open (hover to select)”, selection may
lose at mouse movement.
» “Use check box to select” option in “Folder Options” of Windows
control panel has no effect in TE.
Full Row Select Temporarily disable full row selection when the * Use this add-on if you 1.00
Ex mouse pointer is in a file list 1. have opted “single click to open (hover to select)” in “Folder 2013/7/31

Options” of Windows control panel
2. have opted “full row select” in “Tools > Options > List > Style”
3. often need to hover beside an item to see its tip popup but do
not want to affect the selection you have made
» Usually this add-on is not needed.




9. Statistics
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Status Bar Display item count or selection count, like the You can opt to display on the title bar. Then you also need to: 1.09
default behavior of Windows + Set the location to “outside of the TE window” 2017/4/4
+ Disable “Title bar” add-on
Count bar Display both item count and selection count You can opt to display on the title bar. Then you also need to: 1.01
+ Set the location to “outside of the TE window” 2016/3/17
+ Disable “Title bar” add-on
Size status bar Display available drive space (when no file is Size of folder is not included. 1.02
selected) or total size of selected files 2015/11/15
Full path bar Display the full path of: * You can opt to display on the title bar. Then you also need to: 1.02
« the current folder (when no item is selected), or = Set the location to “outside of the TE window” 2016/3/17
« the current selection = Disable “Title bar” add-on
« If multiple items are selected, only the full path of the last
selection will be displayed.
10. Clipboard
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Cut Command button to cut selected items to 1.00
Windows clipboard 2016/12/6
Copy Command button to copy selected items to 1.00
Windows clipboard 2016/12/6
Paste Command button to paste all items in Windows 1.01
clipboard to the current folder 2017/11/20
Clipboard Command button of clipboard operations “Paste source” includes: 1.04
+ Click: Show an action menu (cut, copy and » whether the source items are cut or copied, and 2015/11/15
paste) with paste source + the item names
» Drop to the button: Copy the dropped items
+ Shift+Drop to the button: Cut the dropped items
Clipboard history | Record a few cut and copy operations, and let you |« Steps to use: 1.04
choose to paste using a context menu. 1. Do a few cut and copy operations. 2016/10/3
2. Right click an empty space of the destination folder.
3. Choose the source to paste.
4. Choose to copy, move or create shortcut.
* You can customize the maximum number of cut and copy
operations to record. The default is 15.
Clipboard Copy Let you paste the full paths of any cut or copied 1.03
items to another application 2016/3/16




11. File Operations

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Multi process Use a separated process for any file/folder Cannot be used together with “Multi Thread” add-on. 1.18
copy/move/delete operation so that TE does not 2017/11/16
freeze during the operation
Multi Thread Use a separated process for any file/folder Cannot be used together with “Multi process” add-on. 1.15
copy/move/delete operation so that TE does not 2017/8/28
freeze during the operation
Rename Dialog Show a dialog box to rename an item File/folder rename can be done without this add-on. 1.00
Box 2014/4/6
Escape Unicode |Command button to check and rename any item |+ TE will ask you to confirm the new names before the operation. 1.02
in the current folder for Unicode characters » Useful if you have trouble accessing these items, especially 2015/2/24
» Escape: Rename away from Unicode when you transfer them to a different file system that does not
* Unescape: Reverse the renaming support Unicode.
Delete Command button to delete selected items TE will ask you to confirm before the operation. 1.01
+ Click: Move to Recycle Bin 2017/2/19
+ Shift+Click: Delete permanently
Empty Recycle Add “Empty Recycle Bin” option to File menu 1.00
Bin 2014/11/3
Move content up | Context command to move all items in the TE will ask you to confirm before the operation. 1.01
selected sub-folders to their parent folder 2015/11/22
12. File Information
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Properties Command button to show the “properties” of 1.02
« the current folder (when no item is selected), or 2017/5/13
+ the selected items
Change the Context command to change the read-only, 1.05
Attributes hidden, system and archive attributes of selected 2016/9/12
items using a dialog box
Change the Date | Context command to change the “modified date 1.09
modified and time” of selected items using a dialog box 2016/11/30
Change the Time | Context command to change 1.07
Stamp » modified date and time 2016/11/30
+ created date and time
+ last accessed date and time
of selected items using a dialog box
13. Folder Tree
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Tree view Command button to show or hide the folder tree To customize the folder tree, choose "Tools > Options > Tree" and 1.27
"Tools > Options > Tree > Root". Restart TE to take effect. 2017/9/24




Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Side tree view Shared folder tree for all tabs and panes + To toggle like regular Tree View, use “Add-on Switcher” add-on. 1.08
+ To customize the folder tree, choose "Tools > Options > Tree" 2017/10/12
and "Tools > Options > Tree > Root". Restart TE to take effect.
Disable Tree Drop | Disable drag-and-drop to the folder tree » “Disable Drag-and-Drop” option in “Tools > Options > Tree” can 1.02
1. from another tree node, and help case 1 only. Use this add-on to achieve all 3 cases. 2016/3/15
2. from a file list, and » Drag from the folder tree to outside (to the tab area to open a
3. from another application folder, for example) is not affected.
4. Favorites
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Favorites Command button to show the Favorites menu 1.02
2016/12/6
Add to Favorites | Command button to add current folder to the 1.02
Favorites menu 2017/8/20
Add all tabs to Menu option to add all tabs of the active pane to | You can open multiple folders by one click to a group item. 1.00
favorites the Favorites menu as a group item 2014/10/31
Horizontal Tool bar of the favorites items 1.1
Favorites bar * Click an item: Open the item 2017/6/11
* Right click an item: Context menu
* Drop to an item: File copy/move the dragged
source to the item
» Drop to an empty space of the tool bar: Add the
dragged source to the Favorites menu
Favorites bar Vertical tool bar of the favorites items shown one 1.22
on each line 2017/4/1
+ Click an item: Open the item
* Right click an item: Context menu
» Drop to an item: File copy/move the dragged
source to the item
» Drop to an empty space of the tool bar: Add the
dragged source to the Favorites menu
Favorites Open in | Set user preference: Open the folder in a new tab, 1.00
a New Tab instead of the default of the current tab, when a 2013/7/7

favorites item is selected.




15. Tabs

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Tabs Enriched tab functions: To customize the appearance of tabs, choose "Tools > Options > 1.20
1. Show folder path in tip popup Tabs". 2017/3/24
2. Enable tab arrangement within a pane and
among panes
3. Open a folder in a new tab by drag-and-drop to
the tab area
4. Enable file copy and move operations by drag-
and-drop items to another tab
Tab plus Functions of "Tabs" add-on, plus: » Customizations through "Tools > Options > Tabs" do not apply to 1.38
1. Icon on tab this add-on. Use “Tab design” add-on if needed. 2017/6/28
2. “Close” button on tab * When this add-on is enabled, "Tabs" add-on can be disabled.
3. “New tab” button in tab area
4. Background color to highlight the active pane
Tab design Customize the appearance of tabs Tab plus 1.06
+ 4 predefined styles are available 2017/4/18
» Advanced users can specify their own (in CSS
syntax)
Change Tab Color | Context command to set a color to a tab, i.e. a tabcolor.xml Tab plus 1.04
specific folder 2016/3/14
Tab color plus Display the tab in specific color when the folder tabcolorplus.tsv Tab plus 1.01
path matches a specific pattern 2016/3/1
Tab Drive Name | Display drive letter additionally on tab 1.04
2016/1/7
Tab Parent Folder | Display parent folder name additionally on tab 1.01
Name 2013/2/12
Name the Tab Display a specific name, instead of the folder tabname.xml 1.05
name, on tab for a specific folder 2017/5/11
Tab position Set user preference of 1.03
1. new tab position 2017/8/19
2. tab to become active after a tab is closed
Locked tabs top | Automatically arrange all locked tabs together at 1.04
the left 2017/10/12
New Tab Command button to add a tab 1.03
2012/2/11
Close duplicate Context command to close any duplicated tab in 1.01
tabs the current pane 2016/11/2




-—

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Prevent Duplicate | Automatically prevent from any duplicated tabin |« When a tab is added (by clicking a “new tab” button, for 1.06
Tabs the same pane example), the “Recent ltems” folder will be opened, instead of 2016/12/30
the default of a duplicate of the current folder.
* When a folder is chosen to open (by choosing it from the
Favorites menu, for example) and is found duplicated, it will not
be opened.
* When you navigate to a folder which is already opened in
another tab, the tab will be closed.
» Prevention works on pane basis. The same folder can still be
opened or be navigated to on another pane.
6. Panes
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Split Tool bar of 4 buttons to change layout to: 1.04
* single pane 2015/2/23
* 2 horizontal panes
+ 2 vertical panes
* 2X2 panes
Split3 Tool bar of 2 buttons to change layout to: 1.01
+ 3 vertical panes 2017/7/30
* 3 horizontal panes
Split6 Tool bar of 2 buttons to change layout to: 1.00
+ 3x2 panes 2015/2/23
» 2x3 panes
Switch to next Enable switching to the next pane by a hot key, a 1.01
pane mouse gesture, a command button or a menu 2017/9/4
option
Inactive pane Change the background color of file list and folder | Background color may be missing from a sort column in details 1.02
tree of all inactive panes so that the active pane | view. Use “Color” or “No emphasis” add-on to solve the problem. 2016/10/5
can stand out
Inner Individual breadcrumbs address bar for each pane 1.23
Breadcrumbs 2017/10/14
Address Bar
Inner Address Bar | Individual classic address bar for each pane 1.22
2017/12/21
Inner Back Individual Back command button for each pane 1.04
2015/1/21
Inner Forward Individual Forward command button for each pane 1.05
2015/1/21
Inner Up Individual Up command button for each pane 1.02
2015/1/21
Inner Refresh Individual Refresh command button for each pane 1.01

2015/1/21




-—

-—

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Inner New folder | Individual New Folder command button for each 1.00
pane 2015/5/16
Inner Filter bar Individual Filter Bar for each pane 1.16
2017/8/5
Inner Search bar | Individual Search Bar for each pane 1.04
2017/12/15
7. Workspaces
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Tab groups A workspace (tab group) is a collection of of tabs |+ Each workspace can have its set of tabs and pane layout. 1.19
and panes you work with. This add-on lets you * You can save a workspace as a file and load it later. 2016/6/3
open several workspaces at the same time, and * You can drag-and-drop objects among the workspaces.
switch among them by clicking the workspace » TE saves all opened workspaces when it exits, and restores
tabs. them when it starts.
* Right click a workspace tab to access its functions.
8. Links (unconfirmed)
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Folder list menu Show a menu of folders listed in a text file 1.05
2017/7/19
Clip folder A clip folder is a virtual folder that can hold any » Aclip folder is actually a text file encoded in UTF-8 with BOM, 1.10
files and folders from anywhere in the computer. It | and has an extension of cfu. 2017/7/18
is similar to a regular folder that stores shortcuts, |+ Right click an empty space of a folder to create a clip folder.
except that the target files and folders are Alternatively you can use any application to create a cfu file.
presented as themselves. * Click a cfu file to open it like a regular folder.
9. Preview and Image
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Preview Display the contents of the selected file in a » Supported text file types include txt, css, js, vbs, vba and ini. 1.1
preview pane. Text, image and media files are + Basic information is displayed for unsupported file types and 2017/4/4
supported. folders.
Archive image Enable the preview pane to display image files Preview 1.01
stored in a zip archive 2017/2/28
Menu Image List the selected image files in a context menu, 1.00
and show a preview in a popup when the mouse 2013/12/8
pointer hovers on the menu option.
Tooltip preview Show a preview in a popup when the mouse Cannot be used together with “No infotip” add-on 1.03
pointer hovers beside an image file 2017/3/2
Retouch Image resize and rotation tool To use, select an image file and 1.04
* click the command button, or 2017/2/21

» choose “Edit > Retouch...”




20. Ranking and Labels

+ Example: “1d” will match any item accessed in the past 86400
seconds.
* 1 year is assumed 365 days. No leap year handling.

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Badge Context commands to manage file/folder ranking |+ Steps to use: badge.tsv 1.04
for sorting and searching 1. Select one or more items in a file list 2017/8/12
2. Right click the selection to show the Badge menu
3. Choose:
= 0 to 5: Assign to this rank
= Open: Search for items with this rank and list them in a tab
= Sort: Sort the file list by rank
* File/folder rank is displayed as an icon overlay.
Label Context commands to manage user-defined + Steps to use: label.tsv 1.19
file/folder labels for sorting and searching 1. Select one or more items in a file list 2017/8/12
2. Right click the selection to show the Label menu
3. Choose:
= Edit/ Add / Remove: Manage labels
= Details: Show the label column
= Sort: Sort the file list by labels
+ To search for files/folders with a specific label, input “label:” and
then the label text to address bar. Alternatively (and more easily)
use “Label button” add-on.
Label button Command button to manage labels Click to show a menu: Label 1.04
+ Edit/ Add / Remove: Manage labels 2016/2/1
* Details: Show the label column
* label text: Search for items with this label and list them in a tab
Label groups Organize labels in user-defined groups + Labels will be divided into groups in the menus. labelgroups.tsv Label 1.01
» Alabel can be assigned to more than one group. 2015/12/18
21. Highlight
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Color labels Context command to set background color to the | Background color may be missing from a sort column in details colorlabels.tsv 1.01
selected items view. Use “Color” or “No emphasis” add-on to solve the problem. 2017/8/16
Colored with Display the item name in specific color for a extensioncolor.tsv 1.01
extension specific file type 2015/5/17
Colored with Display the item name in specific color if an item |+« Elapsed time can be specified in seconds, minutes, hours, days, | modifydatecolor.tsv 1.03
modify date is modified in a specific elapsed time weeks or years, but the actual calculation will be in seconds. 2017/1/23
+ Example: “1d” will match any item modified in the past 86400
seconds.
» 1 year is assumed 365 days. No leap year handling.
Colored with Display the item name in specific color if an item |+ Elapsed time can be specified in seconds, minutes, hours, days, | accessdatecolor.tsv 1.01
access date is accessed in a specific elapsed time weeks or years, but the actual calculation will be in seconds. 2017/1/23




Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Colored with Display the item name in specific color if an item  Elapsed time can be specified in seconds, minutes, hours, days, | createdatecolor.tsv 1.01
create date is created in a specific elapsed time weeks or years, but the actual calculation will be in seconds. 2017/1/23
« Example: “1d” will match any item created in the past 86400
seconds.
» 1 year is assumed 365 days. No leap year handling.
Colored with Display the item name in specific color if an item 1.02
attributes has a specific attribute (e.g. read-only, hidden, 2016/9/28
system, etc.)
22. Icon Replacement
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Extension icon Display another icon for a specific file type extensionicon.tsv 1.06
changer 2017/8/12
Path icon changer | Display another icon for a specific file/folder path pathicon.tsv 1.03
2017/8/12
Filter icon changer | Display another icon when the file/folder path filtericon.tsv 1.01
matches a specific pattern 2017/8/12
Icon Changer 1. Display another icon for: * “Undefined” means that the file type is not associated with any | iconchanger.tsv 1.04
= opened folder application in Windows. 2016/10/10
= closed folder « If a specific file type is added to the configuration list of this add-
= all undefined file types on, it must have been associated with an application. Otherwise
= a specific file type nothing will happen.
2. Display another icon overlay for:
= shortcut
= network share
23. Application Appearance
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
A Title bar Change TE's window title to “active tab name - 1.04
Tablacus Explorer” 2017/9/10
Hide Title bar Do not display TE’s title bar 1.00
2017/4/3
Folder Icon Use a folder as TE'’s icon 1.01
2015/1/30
Application Icon | Customize TE's icon 1.01
2017/3/15
Font settings Customize the font used by TE 1.05
2017/8/21
Color Customize the font color and background color of 1.05

file list and folder tree

2017/5/22




Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
List width Use a user-specified width to display each item in | If your folder stores many items with very long names, this add-on 1.00
list view (item name may be shortened), instead of | will speed up scrolling because more items can be displayed in 2015/2/2
Windows default of varying width (full item name | each page.
is displayed)
Fast list mode Use the same width as small icon view to display |« If your folder stores many items with very long names, this add- 1.01
each item in list view (item name may be on will speed up scrolling because more items can be displayed 2017/8/17
shortened), instead of Windows default of varying in each page.
width (full item name is displayed) * Require Window Vista or higher
Gridlines Display grid lines in details view 1.03
2017/2/13
Stripes Display alternating stripes in the background in Stripes may be missing from a sort column. Use “Color” or “No 1.07
details view emphasis” add-on to solve the problem. 2017/3/14
Stripes lite Display alternating stripes in the background in Stripes may be missing from a sort column. Use “Color” or “No 1.03
details view emphasis” add-on to solve the problem. 2017/7/2
No emphasis Do not change the background color of a sort Use this add-on when: 1.00
column in details view + you do not need emphasis on a sort column (Windows XP only) 2017/3/14
« there is a background color problem in a sort column
User style sheet | Customize TE'’s appearance using CSS This add-on is for advanced users. user.css 1.01
2016/3/13
4. Fine Tuning
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
To the top in the Bring TE window to the top when anything is 1.02
drag dragged from another application 2016/3/15
No infotip Do not display any tip popup when the mouse If you have opted the same in “Folder Options” of Windows control 1.00
pointer hovers on a folder or a file panel, you do not need this add-on. 2016/4/21
Quickly open Show a simplified context menu when you right  Useful if your context menu is bulky. 1.09
menus click in afile list or in the folder tree * You can choose “Default” to show the original menu. 2017/6/10
Notepad Run your text editor instead of Windows Notepad [your text editor] 1.01
alternative when TE runs the latter 2017/4/18
Replace Run your text editor instead of Windows Notepad |+ To use, change “$1” to the path of your text editor in the add-on [your text editor] 1.01
Command when you select a text file and press Shift+F2 configuration page. 2017/3/23

» This add-on can potentially replace any default application run
by TE by your application. However currently there is not any
such application other than Notepad.

+ Usually this add-on is not needed.




25. Startup and Settings

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Startup settings Do something when TE starts, e.g. open a folder | Example: 1.04
1. Choose “Tools > Add-ons” 2015/10/22
2. Click “Options” of “Startup settings”
3. Type: choose “Open in new tab”
4. Options: choose My Documents (click Reference... to choose)
Restart Restart TE by a hot key, a mouse gesture, a 1.03
command button or a menu option 2016/3/17
Auto restart Restart TE after a period of inactivity You can specify the period in hours:minutes format. 1.00
2016/9/28
Auto save By default, TE saves its settings when needed You can specify a time period in minutes. The default is 5. 1.02
and when it exits. This add-on let TE also save the 2016/2/29
settings periodically.
Save custom Save your custom colors added to the Windows custcolors.txt 1.00
colors color palette as a part of the TE settings 2017/8/12
Add-on switcher | Toggle the on/off state of another add-on by a hot |« Useful when you need to toggle an add-on frequently but this 1.01
key, a mouse gesture, a command button or a ability is not built-in. 2017/7/8
menu option » Example — to add a tool bar button to toggle Side Tree View:
1. Choose “Tools > Add-ons”
2. Click “Options” of “Tool bar”
3. Add a button with:
= Name: Folder Tree
= Type: Addon switcher
= Options: sidetreeview (click Browse... to choose)
= Icon: choose one you like (click Browse... to choose)
26. Ease of Access
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Systray Opt to show TE icon in Windows System Tray * You can also opt to show the icon whenever TE is running. 1.09
(aka Notification Area) » When this add-on is enabled, you need to choose “Close 2017/8/19
1. when TE is minimized application” menu option to exit TE completely.
2. when TE is closed by clicking the “close” button
in the title bar
Hot Key Set a Windows hot key to bring up TE window TE must be running when the hot key is pressed. 1.00

2015/2/16




27. Replace Windows Explorer

Windows

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Shell execute 1. Run TE instead of Windows Explorer when: * TE needs not be running when it is invoked this way. 1.03
hook = you press Win+E * You can still run Windows Explorer by other ways such as: 2017/8/6
= you run Windows Explorer from: = choose “Computer” from Start Menu
= Start Menu = click Recycle Bin on Desktop
= Task Bar (when pinned) = click a folder shortcut on Desktop or Task Bar
= Run dialog box (Win+R) = choose “Open in Explorer” from tab context menu
= Command Prompt * Running TE from another application may or may not work,
= an application runs Windows Explorer depending on the technique used by that application.
* You can use “Open Instead” add-on to handle cases this add-on
2. Run TE to open the folder in a new tab instead misses.
of Windows Explorer when: + Steps to use (administrator privilege is needed):
= you input a folder path in the Run dialog box 1. In the configuration page of the add-on:
= you input “start <folder path>" in Command = tick all “Registry” options
Prompt = click the “Default” button and reply OK
= an application opens a folder in Windows = tick “Windows Explorer”
Explorer = click OK
2. Your desktop will refresh to complete the configuration.
= If you do not tick “Windows Explorer”, you will need to restart
your computer to complete the configuration.
Open Instead Automatically open the folder in a new tab when it |+ To use, in the configuration page of the add-on: 1.08
is opened in Windows Explorer. The Explorer = Tick “Real Folders” 2017/1/124
window is then closed. = Tick “Special Folders”
= Tick “Take over the Explorer view” (if necessary)
» “Take over the Explorer view” option lets TE take in a folder
together with its current view in Windows Explorer, but the
following Folder View add-ons must not be enabled:
= Take over folder view settings
= Folder settings
Import Explorer Command button to open all folders in new tabs » “Take over the Explorer view” option lets TE take in a folder 1.01
that are currently opened in Windows Explorer. together with its current view in Windows Explorer, but the 2016/3/13
The Explorer windows are then closed. following Folder View add-ons must not be enabled:
= Take over folder view settings
= Folder settings
28. Tools
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Control Panel Command button to show a menu of control panel 1.02
Button items 2016/3/1
Run Command button to show the Run dialog box of 1.01

2013/2/4




29. Developer

+ deselect one or some of them, then
+ sort the file list
the deselected items will incorrectly become selected

Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
System folder Command button to show a menu of system The menu shows a predefined list of folders which application 1.00
folders developers may be interested in. 2017/3/6
30. Fix
Add-on Name Function Note Config File Another add-on or Version
[application] required | Date
Open Control Open control panel in Windows Explorer, instead | To align the behavior with control panel items 1.01
Panel in Explorer |of TE, when it is clicked in the folder tree 2016/3/2
Right key next Align the usage of left/right keys in icon views with | By default, TE stops at the leftmost/rightmost item and does not 1.02
Windows: pressing the left/right key always goes | go up/down when you press the left/right key continuously in icon 2015/12/27
to the previous/next item. views.
Fix selection on Keep your selection after you sort a file list This is a fix to the case that if you: 1.00
sort + select some items, then 2017/2/6

A default add-on

Appendix A — File/Folder Name Pattern

Format:

Examples:

+ AB? match item name with 3 characters and starting with ab
 *ED match item name ended with ed

+ ab?;*ed match any one of the above

a text pattern accepting * and ? as wildcards

* stands for any number of any characters

? stands for any one character

use ; to separate multiple patterns of which any one to match with
case insensitive
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