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1. Input Devices

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Key Customize hot keys There are some predefined defaults. key.xml 1.16
2017/3/23

^ Mouse Customize mouse gestures • There are some predefined defaults.
• More mouse customization options can be found in "Tools > 

Options > General > Mouse".

mouse.xml 1.20
2017/8/16

2. Command Bars

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Main Menu Main menu bar To customize the menu, choose "Tools > Options > Menus". 1.11
2015/12/30

Main Menu Button Command button to show the main menu To change the menu bar to a button:
1. Enable this add-on
2. Disable the “Main Menu” add-on

1.04
2016/5/27

^ Tool bar Customizable tool bar toolbar.xml 1.25
2017/6/11

Link bar Customizable tool bar with drag-and-drop support You can add a button by drag-and-drop an object to an empty 
space of the link bar. The object can be a tab, a folder, a file or a 
program.

linkbar.xml 1.18
2017/6/11

Simple Tool Bar Tool bar of 5 buttons: back, forward, up, new tab 
and refresh.

Its functions can be achieved by individual add-ons which are 
customizable and have more functions.

1.03
2013/3/3

3. Navigation

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Address Bar Breadcrumbs address bar To change to classic style, tick “XP style” in the add-on options. 1.38
2017/10/14

^ Back Command button to go backwards
• Click: Go to last visited folder
• Right click: Show a menu of visited folders

1.09
2014/3/16

^ Forward Command button to go forwards
• Click: Go to the folder just went back from
• Right click: Show a menu of folders went back 

from

1.09
2014/3/16

^ Up Command button to go upwards
• Click: Go to parent folder
• Right click: Show a menu of ascendant folders

1.11
2017/7/27

DriveBar Tool bar of drive buttons
• Click: Open the root folder in a new tab
• Right click: Context menu of the drive

TE can refresh the drive bar automatically when any drive is 
added or removed.

1.08
2016/3/16



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Drive button Command button to show a menu of drives Right click to show the context menu of “Computer”. You can 
connect to or disconnect from a network drive using the menu.

1.03
2017/8/2

Folder button Command button:
• Click: Open a folder as per input to a dialog box
• Right click: Show a menu of sub-folders of the 

current folder

1.01
2016/3/16

Simple Address 
Bar

Text-only address bar • Its functions can be achieved by the breadcrumbs address bar.
• Ctrl+Enter to open a folder in a new tab is not supported.

1.06
2016/3/17

Select tab Switch to the tab with folder path specified in 
“options”

• The folder must already be opened in the active pane.
• Useful if you need to switch to a specific folder frequently using 

a hot key.
• Example:

1. Choose “Tools > Add-ons”
2. Click “Options” of “Key”
3. Add a hot key with:

▪ Key: F12
▪ Type: Select tab
▪ Options: (type in a folder path or click Browse... to choose)

1.00
2016/11/5

Undo Close Tab Context command to re-open the tab last closed closedtabs.xml 1.07
2016/8/22

Recently closed 
tabs

Command button and context command to show 
a menu of recently closed tabs for re-opening

Undo Close Tab 1.01
2016/11/6

History Command button to open a new tab showing a list
of recently opened folders

You can customize the maximum number of folders to record. The
default is 1000.

history.tsv 1.06
2016/8/15

Speed Dial Show a list of recently opened folders when you 
add a tab

The default new tab is changed as such. speeddial.tsv 1.06
2016/3/1

4. Folder View

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Reset Columns Apply the column settings in Windows Explorer 
details view to the current folder

• Menu option: “File > Reset Columns”
• The applied settings may not be remembered by TE unless one 

of the following “Folder View” add-ons is enabled.

1.00
2015/10/15

Remember folder 
view settings

Remember the view of each folder when you 
navigate, like the default behavior of Windows.

remember.xml 1.30
2017/7/15

Take over folder 
view settings

Apply the same view to all file folders
• when you navigate, and
• across TE sessions

• By default, TE adheres to the current view when you navigate, 
but it may change the view unexpectedly when you navigate 
from a file folder to a system folder (such as “Computer”) and 
then back. This add-on solves the problem.

• By default, TE applies the view in Windows Explorer when it 
starts. This add-on lets TE apply the last used view in TE.

takeoverfoldersettings.txt 1.03
2017/7/15



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Folder settings Apply a specific view to a specific folder based on 
folder name pattern

• By default, TE adheres to the current view when you navigate. 
This add-on lets TE adhere to the rules you specified, 
regardless of the current view.

• Steps to use:
1. Customize the view to your need

▪ choose the type of view (icon, list, details, etc.)
▪ choose the columns and the width of each
▪ sort the items (not applicable to query results)

2. Choose “View > Customize this folder”
▪ click “Get the current folder view”
▪ change “Filter” to a folder name pattern if necessary
▪ click “Add”

• Filter format:
▪ see Appendix A
▪ special folder is represented by a number
▪ query result is represented as query:
▪ examples:

▫ Local and network file folders ?:\*;\\*
▫ Computer 17
▫ Recycle bin 10
▫ Browsing history history:
▫ Everything search result es:*

• First set up the view for general file folders. Then set up the 
views for exceptions.

foldersettings.xml 1.14
2017/7/16

5. Working with Folders

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Refresh Command button to refresh the file list of the 
current folder

1.05
2015/7/1

Mixed sort Command button to sort files and folders together 
(Windows sorts them separately). You can sort by 
name or modified date, in ascending or 
descending order.

• This sorting order cannot be preserved in a folder view.
• Require Window Vista or higher

1.01
2015/6/16

Total file size sort Command button to sort all items by “Total File 
Size” in descending order, and display the column
if not yet.

• “Total File Size” is:
▪ for a folder: total size of all files under the folder branch
▪ for a file: same as its size

• This sorting order cannot be preserved in a folder view.
• Require Window Vista or higher

1.02
2015/7/1

Flat Tab context command to show all items under the 
current folder branch as a flat list

1.01
2017/3/23

Replace slow 
columns

TE automatically replaces the slow "Date" column 
with the fast "Modified Date" column when you 
browse, if the latter is not currently in the view.

Usually this add-on is not needed because the slow “Date” column
is not a default.

1.02
2017/10/9

6. Filter, Search and Select



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Filter bar Show items with names matching an input filter 
and hide those do not

• Filter format:
▪ see Appendix A
▪ If only normal text is specified (no * ? ;), any item with its 

name containing the text anywhere will be matched.
• Can opt to support regular expression and Migemo

1.19
2017/8/5

Filter list Click the filter icon to show a menu of user-
defined filters

filterlist.tsv Filter bar 1.01
2017/8/6

Filter button Command button to input a filter 1.00
2016/2/23

Search bar File/folder search using Windows Search Windows Search can still be invoked by pressing Ctrl+F even 
without this add-on.

1.03
2017/4/9

Everything File/folder search using Everything Can opt to support regular expression and Migemo [Everything] 1.22
2017/6/5

Find files Search by file name (accept wildcards) and/or by 
text contents (case insensitive)

• Default hot key is F3
• Folders are excluded from search
• See Appendix A for input file name format

1.04
2017/4/6

Empty folder Search for any empty sub-folder under the branch
of:
• the current folder (when no item is selected), or
• the selected folders
then list the result in a new tab

1.06
2017/2/6

Wildcard 
Selection

Select items with names matching an input 
pattern

• Menu option: “Edit > Wildcard Select…”
• See Appendix A for input pattern format

1.00
2013/9/9

Check box Use a check box beside each item for selection • To use this add-on, you must opt “double click to open (single 
click to select)” in “Folder Options” of Windows control panel. If 
you opt “single click to open (hover to select)”, selection may 
lose at mouse movement.

• “Use check box to select” option in “Folder Options” of Windows
control panel has no effect in TE.

1.03
2015/5/30

Full Row Select 
Ex

Temporarily disable full row selection when the 
mouse pointer is in a file list

• Use this add-on if you
1. have opted “single click to open (hover to select)” in “Folder 

Options” of Windows control panel
2. have opted “full row select” in “Tools > Options > List > Style”
3. often need to hover beside an item to see its tip popup but do

not want to affect the selection you have made
• Usually this add-on is not needed.

1.00
2013/7/31

7. Statistics

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Status Bar Display item count or selection count, like the 
default behavior of Windows

You can opt to display on the title bar. Then you also need to:
• Set the location to “outside of the TE window”
• Disable the “title bar” add-on

1.09
2017/4/4



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Count bar Display both item count and selection count You can opt to display on the title bar. Then you also need to:
• Set the location to “outside of the TE window”
• Disable the “title bar” add-on

1.01
2016/3/17

Size status bar Display available drive space (when no file is 
selected) or total size of selected files

Size of folder is not included. 1.02
2015/11/15

Full path bar Display the full path of:
• the current folder (when no item is selected), or
• the current selection

• You can opt to display on the title bar. Then you also need to:
▪ Set the location to “outside of the TE window”
▪ Disable the “title bar” add-on

• If multiple items are selected, only the full path of the last 
selection will be displayed.

1.02
2016/3/17

8. Clipboard

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Cut Command button to cut selected items to 
Windows clipboard

1.00
2016/12/6

Copy Command button to copy selected items to 
Windows clipboard

1.00
2016/12/6

Paste Command button to paste all items in Windows 
clipboard to the current folder

1.01
2017/11/20

Clipboard Command button of clipboard operations
• Click: Show an action menu (cut, copy and 

paste) with paste source
• Drop to the button: Cut or copy the dropped 

items

“Paste source” includes:
• whether the source items are cut or copied, and
• the item names

1.04
2015/11/15

Clipboard history Record a few cut and copy operations, and let you
choose to paste using a context menu.

• Steps to use:
1. Do a few cut and copy operations.
2. Right click an empty space of the destination folder.
3. Choose the source to paste.
4. Choose to copy, move or create shortcut.

• You can customize the maximum number of cut and copy 
operations to record. The default is 15.

1.04
2016/10/3

Clipboard Copy Let you paste the full paths of any cut or copied 
items to another application 

1.03
2016/3/16

9. File Operations

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Multi process Use a separated process for any file/folder 
copy/move/delete operation so that TE does not 
freeze during the operation

Cannot be used together with “Multi Thread” add-on. 1.18
2017/11/16

Multi Thread Use a separated process for any file/folder 
copy/move/delete operation so that TE does not 
freeze during the operation

Cannot be used together with “Multi process” add-on. 1.15
2017/8/28



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Rename Dialog 
Box

Show a dialog box to rename a file File rename can be done without this add-on. 1.00
2014/4/6

Delete Command button to delete selected items 1.01
2017/2/19

Empty Recycle 
Bin

Add “Empty Recycle Bin” option to File menu 1.00
2014/11/3

Move content up Context command to move all items in the 
selected sub-folders to their parent folder

1.01
2015/11/22

10. File Information

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Properties Command button to show the “properties” of
• the current folder (when no item is selected), or
• the selected items

1.02
2017/5/13

Change the 
Attributes

Context command to change the read-only, 
hidden, system and archive attributes of selected 
items using a dialog box

1.05
2016/9/12

Change the Date 
modified

Context command to change the “modified date 
and time” of selected items using a dialog box

1.09
2016/11/30

Change the Time 
Stamp

Context command to change
• modified date and time
• created date and time
• last accessed date and time
of selected items using a dialog box

1.07
2016/11/30

11. Folder Tree

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Tree view Command button to show or hide the folder tree To customize the folder tree, choose "Tools > Options > Tree" and 
"Tools > Options > Tree > Root". Restart TE to take effect.

1.27
2017/9/24

Side tree view Shared folder tree for all tabs and panes • To toggle like regular Tree View, use “Add-on Switcher” add-on.
• To customize the folder tree, choose "Tools > Options > Tree" 

and "Tools > Options > Tree > Root". Restart TE to take effect.

1.08
2017/10/12

Disable Tree Drop Disable drag-and-drop to the folder tree
1. from another tree node, and
2. from a file list, and
3. from another application

• “Disable Drag-and-Drop” option in “Tools > Options > Tree” can 
help case 1 only. Use this add-on to achieve all 3 cases.

• Drag from the folder tree to outside (to the tab area to open a 
folder, for example) is not affected.

1.02
2016/3/15

12. Favorites



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Favorites Command button to show the Favorites menu 1.02
2016/12/6

Add to Favorites Command button to add current folder to the 
Favorites menu

1.02
2017/8/20

Add all tabs to 
favorites

Menu option to add all tabs of the active pane to 
the Favorites menu as a group item

You can open multiple folders by one click to a group item. 1.00
2014/10/31

Horizontal 
Favorites bar

Tool bar of the favorites items
• Click an item: Open the item
• Right click an item: Context menu
• Drop to an item: File copy/move the dragged 

source to the item
• Drop to an empty space of the tool bar: Add the 

dragged source to the Favorites menu

1.11
2017/6/11

Favorites bar Vertical tool bar of the favorites items shown one 
on each line
• Click an item: Open the item
• Right click an item: Context menu
• Drop to an item: File copy/move the dragged 

source to the item
• Drop to an empty space of the tool bar: Add the 

dragged source to the Favorites menu

1.22
2017/4/1

Favorites Open in 
a New Tab

Set user preference: Open the folder in a new tab,
instead of the default of the current tab, when a 
favorites item is selected.

1.00
2013/7/7

13. Tabs

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Tabs Enriched tab functions:
1. Show folder path in tip popup
2. Enable tab arrangement within a pane and 

among panes
3. Open a folder in a new tab by drag-and-drop to 

the tab area
4. Enable file copy and move operations by drag-

and-drop items to another tab

To customize the appearance of tabs, choose "Tools > Options > 
Tabs".

1.20
2017/3/24

Tab plus Functions of "Tabs" add-on, plus:
1. Icon on tab
2. “Close” button on tab
3. “New tab” button in tab area
4. Background color to highlight the active pane

• The tabs appear in Aero style.
• Customizations through "Tools > Options > Tabs" do not apply to

this add-on. Use “Tab design” add-on if needed.
• When this add-on is enabled, "Tabs" add-on can be disabled.

1.38
2017/6/28

Tab design Customize the appearance of tabs
• 4 predefined styles are available
• Advanced users can specify their own (in CSS 

syntax)

Tab plus 1.06
2017/4/18



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Change Tab Color Context command to set a color to a tab, i.e. a 
specific folder

tabcolor.xml Tab plus 1.04
2016/3/14

Tab color plus Display the tab in specific color when the folder 
path matches a specific pattern

tabcolorplus.tsv Tab plus 1.01
2016/3/1

Tab Drive Name Display drive letter additionally on tab 1.04
2016/1/7

Tab Parent Folder 
Name

Display parent folder name additionally on tab 1.01
2013/2/12

Name the Tab Display a specific name, instead of the folder 
name, on tab for a specific folder

tabname.xml 1.05
2017/5/11

Tab position Set user preference of
1. new tab position
2. tab to become active after a tab is closed

1.03
2017/8/19

Locked tabs top Automatically arrange all locked tabs together at 
the left

1.04
2017/10/12

New Tab Command button to add a tab 1.03
2012/2/11

Close duplicate 
tabs

Context command to close any duplicated tab in 
the current pane

1.01
2016/11/2

Prevent Duplicate 
Tabs

Automatically prevent from any duplicated tab in 
the same pane

• When a tab is added (by clicking a “new tab” button, for 
example), the “Recent Items” folder will be opened,  instead of 
the default of a duplicate of the current folder.

• When a folder is chosen to open (by choosing it from the 
Favorites menu, for example) and is found duplicated, it will not 
be opened.

• When you navigate to a folder which is already opened in 
another tab, the tab will be closed.

• Prevention works on pane basis. The same folder can still be 
opened or be navigated to on another pane.

1.06
2016/12/30

14. Panes

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Split Tool bar of 4 buttons to change layout to:
• single pane
• 2 horizontal panes
• 2 vertical panes
• 2x2 panes

1.04
2015/2/23

Split3 Tool bar of 2 buttons to change layout to:
• 3 vertical panes
• 3 horizontal panes

1.01
2017/7/30

Split6 Tool bar of 2 buttons to change layout to:
• 3x2 panes
• 2x3 panes

1.00
2015/2/23



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Switch to next 
pane

Enable switching to the next pane by a hot key, a 
mouse gesture, a command button or a menu 
option

1.01
2017/9/4

Inactive pane Change the background color of file list and folder 
tree of all inactive panes so that the active pane 
can stand out

1.02
2016/10/5

Inner 
Breadcrumbs 
Address Bar

Individual breadcrumbs address bar for each pane 1.23
2017/10/14

Inner Address Bar Individual classic address bar for each pane 1.21
2017/8/16

Inner Back Individual Back command button for each pane 1.04
2015/1/21

Inner Forward Individual Forward command button for each pane 1.05
2015/1/21

Inner Up Individual Up command button for each pane 1.02
2015/1/21

Inner Refresh Individual Refresh command button for each pane 1.01
2015/1/21

Inner New folder Individual New Folder command button for each 
pane

1.00
2015/5/16

Inner Filter bar Individual Filter Bar for each pane 1.16
2017/8/5

Inner Search bar Individual Search Bar for each pane 1.03
2017/4/9

15. Workspaces

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Tab groups A workspace (tab group) is a collection of of tabs 
and panes you work with. This add-on lets you 
open several workspaces at the same time, and 
switch among them by clicking the workspace 
tabs.

• Each workspace can have its set of tabs and pane layout.
• You can save a workspace as a file and load it later.
• You can drag-and-drop objects among the workspaces.
• TE saves all opened workspaces when it exits, and restores 

them when it starts.

1.19
2016/6/3

16. (unsure)

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Folder list menu Show a menu of folders listed in a text file 1.05
2017/7/19



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Clip folder A clip folder is a virtual folder that can hold any 
files and folders from anywhere in the computer. It
is similar to a regular folder that stores shortcuts, 
except that the target files and folders are 
presented as themselves.

• A clip folder is actually a text file encoded in UTF-8 with BOM, 
and has an extension of cfu.

• Right click an empty space of a folder to create a clip folder. 
Alternatively you can use any application to create a cfu file.

• Click a cfu file to open it like a regular folder.

1.10
2017/7/18

17. Preview

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Preview Display the contents of the selected file in a 
preview pane. Text, image and media files are 
supported.

• Supported text file types include txt, css, js, vbs, vba and ini.
• Basic information is displayed for unsupported file types and 

folders.

1.11
2017/4/4

Archive image Enable the preview pane to display image files 
stored in a zip archive

Preview 1.01
2017/2/28

Menu Image List the selected image files in a context menu, 
and show a preview in a popup when the mouse 
pointer hovers on the menu option.

1.00
2013/12/8

Tooltip preview Show a preview in a popup when the mouse 
pointer hovers beside an image file

Cannot be used together with “No infotip” add-on 1.03
2017/3/2

18. Labels

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Label Context commands to manage user-defined 
file/folder labels for sorting and searching

To search for files/folders with a specific label, input “label:” and 
then the label text to address bar. Alternatively (and more easily) 
use the “Label button” add-on.

label.tsv 1.19
2017/8/12

Label button Command button to manage labels Label 1.04
2016/2/1

Label groups Organize labels in user-defined groups labelgroups.tsv Label 1.01
2015/12/18

19. Highlight

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Color labels Context command to set background color to the 
selected items

colorlabels.tsv 1.01
2017/8/16

Colored with 
extension

Display the item name in specific color for a 
specific file type

extensioncolor.tsv 1.01
2015/5/17

Colored with 
modify date

Display the item name in specific color if an item 
is modified in a specific elapsed time

• Elapsed time can be specified in seconds, minutes, hours, days,
weeks or years, but the actual calculation will be in seconds.

• Example: “1d” will match any item modified in the past 86400 
seconds.

• 1 year is assumed 365 days. No leap year handling.

modifydatecolor.tsv 1.03
2017/1/23



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Colored with 
access date

Display the item name in specific color if an item 
is accessed in a specific elapsed time

• Elapsed time can be specified in seconds, minutes, hours, days,
weeks or years, but the actual calculation will be in seconds.

• Example: “1d” will match any item accessed in the past 86400 
seconds.

• 1 year is assumed 365 days. No leap year handling.

accessdatecolor.tsv 1.01
2017/1/23

Colored with 
create date

Display the item name in specific color if an item 
is created in a specific elapsed time

• Elapsed time can be specified in seconds, minutes, hours, days,
weeks or years, but the actual calculation will be in seconds.

• Example: “1d” will match any item created in the past 86400 
seconds.

• 1 year is assumed 365 days. No leap year handling.

createdatecolor.tsv 1.01
2017/1/23

Colored with 
attributes

Display the item name in specific color if an item 
has a specific attribute (e.g. read-only, hidden, 
system, etc.)

1.02
2016/9/28

20. Icon Replacement

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Extension icon 
changer

Display another icon for a specific file type extensionicon.tsv 1.06
2017/8/12

Path icon changer Display another icon for a specific file/folder path pathicon.tsv 1.03
2017/8/12

Filter icon changer Display another icon when the file/folder path 
matches a specific pattern

filtericon.tsv 1.01
2017/8/12

Icon Changer 1. Display another icon for:
▪ opened folder
▪ closed folder
▪ all undefined file types
▪ a specific file type

2. Display another icon overlay for:
▪ shortcut
▪ network share

• “Undefined” means that the file type is not associated with any 
application in Windows.

• If a specific file type is added to the configuration list of this add-
on, it must have been associated with an application. Otherwise 
nothing will happen.

iconchanger.tsv 1.04
2016/10/10

21. Application Appearance

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

^ Title bar Change TE's window title to “tab name - Tablacus 
Explorer”

1.04
2017/9/10

Hide Title bar Do not display TE’s title bar 1.00
2017/4/3

Folder Icon Use a folder as TE’s icon 1.01
2015/1/30

Application Icon Customize TE's icon 1.01
2017/3/15



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Font settings Customize the font used by TE 1.05
2017/8/21

Color Customize the font color and background color of 
file list and folder tree

1.05
2017/5/22

List width Use a user-specified width to display each item in 
list view (item name may be shortened), instead of
Windows default of varying width (full item name 
is displayed)

If your folder stores many items with very long names, this add-on 
will speed up scrolling because more items can be displayed in 
each page.

1.00
2015/2/2

Fast list mode Use the same width as small icon view to display 
each item in list view (item name may be 
shortened), instead of Windows default of varying 
width (full item name is displayed)

• If your folder stores many items with very long names, this add-
on will speed up scrolling because more items can be displayed 
in each page.

• Require Window Vista or higher

1.01
2017/8/17

Gridlines Display grid lines in details view 1.03
2017/2/13

Stripes Display alternating stripes in the background in 
details view

[Internet Explorer 8 
or higher] on 
Windows XP

1.07
2017/3/14

Stripes lite Display alternating stripes in the background in 
details view

1.03
2017/7/2

22. Fine Tuning

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

To the top in the 
drag

Bring TE window to the top when anything is 
dragged from another application

1.02
2016/3/15

No infotip Do not display any tip popup when the mouse 
pointer hovers on a folder or a file

If you have opted the same in “Folder Options” of Windows control
panel, you do not need this add-on.

1.00
2016/4/21

23. Automation

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Startup settings Do something when TE starts, e.g. open a folder Example:
1. Choose “Tools > Add-ons”
2. Click “Options” of “Startup settings”
3. Type: choose “Open in new tab”
4. Options: choose My Documents (click Reference... to choose)

1.04
2015/10/22

Restart Restart TE by a hot key, a mouse gesture, a 
command button or a menu option

1.03
2016/3/17

Auto restart Restart TE after a period of inactivity You can specify the period in hours:minutes format. 1.00
2016/9/28

Auto save By default, TE saves its settings when needed 
and when it exits. This add-on let TE also save the
settings periodically.

You can specify a time period in minutes. The default is 5. 1.02
2016/2/29



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Save custom 
colors

Save your custom colors added to the Windows 
color palette as a part of the TE settings

custcolors.txt 1.00
2017/8/12

Add-on switcher Toggle the on/off state of another add-on by a hot 
key, a mouse gesture, a command button or a 
menu option

• Useful when you need to toggle an add-on frequently but this 
ability is not built-in.

• Example – to add a tool bar button to toggle Side Tree View:
1. Choose “Tools > Add-ons”
2. Click “Options” of “Tool bar”
3. Add a button with:

▪ Name: Folder Tree
▪ Type: Addon switcher
▪ Options: sidetreeview (click Browse… to choose)
▪ Icon: choose one you like (click Browse… to choose)

1.01
2017/7/8

24. Ease of Access

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Systray Opt to show TE icon in Windows System Tray 
(aka Notification Area)
1. when TE is minimized
2. when TE is closed by clicking the “close” button

in the title bar

• You can also opt to show the icon whenever TE is running.
• When this add-on is enabled, you need to use the “Close 

application” menu option to exit TE completely.

1.09
2017/8/19

Hot Key Set a Windows hot key to bring up TE window TE must be running when the hot key is pressed. 1.00
2015/2/16

25. Tools

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Control Panel 
Button

Command button to show a menu of control panel
items for opening

1.02
2016/3/1

Run Command button to show the Run dialog box of 
Windows

1.01
2013/2/4

Retouch Image resize and rotation tool To use, select an image file and click the command button 1.04
2017/2/21

26. Developer

Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

System folder Command button to show a menu of system 
folders

The menu shows a predefined list of folders which application 
developers may be interested in.

1.00
2017/3/6

27. Fix



Add-on Name Function Note Config File Another add-on or 
[application] required

Version
Date

Open Control 
Panel in Explorer

Open control panel in Windows Explorer, instead 
of TE, when it is clicked in the folder tree

To align the behavior with control panel items 1.01
2016/3/2

Right key next Align the usage of left/right keys in icon views with
Windows: pressing the left/right key always goes 
to the previous/next item.

By default, TE stops at the leftmost/rightmost item and does not 
go up/down when you press the left/right key continuously in icon 
views.

1.02
2015/12/27

Fix selection on 
sort

Keep your selection after you sort a file list This is a fix to the case that if you:
• select some items, then
• deselect one or some of them, then
• sort the file list
the deselected items will incorrectly become selected

1.00
2017/2/6

^ default add-on

Appendix A – File/Folder Name Pattern

Format:
• a text pattern accepting * and ? as wildcards
• * stands for any number of any characters
• ? stands for any one character
• use ; to separate multiple patterns of which any one to match with
• case insensitive
Examples:
• AB? match item name with 3 characters and starting with ab
• *ED match item name ended with ed
• ab?;*ed match any one of the above
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